Bug 181018 - incomplete dependencies in gtkglext-devel : libGLU-devel
incomplete dependencies in gtkglext-devel : libGLU-devel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkglext (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-02-11 14:36 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-14 10:13:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-02-11 14:36:49 EST
Description of problem:
gai-temp doesn't build under current devel/fc5, possibly due to a missing
BuildRequires. 

From the end of the mock build.log: 

gcc -o gai-temp gai-temp.o readtemp.o -pthread -Wl,--export-dynamic -lgai
-lpanel-applet-2 -lgtkglext-x11-1.0 -lgnomeui-2 -lSM -lICE -lbonoboui-2
-lgnome-keyring -lxml2 -lz -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2
-lpangoft2-1.0 -lgnomevfs-2 -lbonobo-2 -lgconf-2 -lbonobo-activation -lORBit-2
-lgthread-2.0 -lgdkglext-x11-1.0 -lGLU -lGL -lgtk-x11-2.0 -lpangox-1.0
-lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0
-lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
/usr/bin/ld: cannot find -lGLU
collect2: ld returned 1 exit status
make: *** [gai-temp] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.11408 (%build)

Possibly needs a BuildRequires of mesa-libGLU?

Full mock output available on request.
Comment 1 Michael Schwendt 2006-02-11 17:15:04 EST
[Reassigning]

This -lGLU comes from a libtool archive found in "gtkglext-devel".

gai-temp buildrequires gai-devel which requires gtkglext-devel
which in turn requires libGL-devel instead of libGLU-devel

Note You need to log in before you can comment on or make changes to this bug.