Bug 1810188 - Error trying to remove event source multiple times
Summary: Error trying to remove event source multiple times
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 16:49 UTC by Beniamino Galvani
Modified: 2020-04-28 16:54 UTC (History)
10 users (show)

Fixed In Version: NetworkManager-1.22.8-4.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:14 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:36 UTC

Description Beniamino Galvani 2020-03-04 16:49:41 UTC
Description of problem:

There is a bug in NM DHCP code that causes a duplicate removal of the same event source. Most of the times this generates a warning (or a crash if debug=fatal-warnings is enabled in NM configuration), but since source events are indexed by id, it is possible that we remove an unrelated event source with the same id, which would be very bad.

The fix is trivial and is already merged upstream:

https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=7a004ef0bb49717606acbf47326a4c6c753cb09b

Version-Release number of selected component (if applicable):
1.22.8-1

How reproducible:
Always when there is a dispatch error in the DHCP client.

FAF crash report:
http://faf.lab.eng.brq.redhat.com/faf/reports/16346/

Comment 9 errata-xmlrpc 2020-04-28 16:54:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.