Bug 181019 - galeon doesn't build under current devel/fc5 mock due to gcc changes
galeon doesn't build under current devel/fc5 mock due to gcc changes
Status: CLOSED DUPLICATE of bug 179783
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-02-11 14:40 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 16:06:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-02-11 14:40:45 EST
Description of problem:
galeon doesn't build under current devel/fc5 mock due to gcc changes.

From the end of the mock build.log: 

 g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../utils -I../utils -I../embed
-I../bookmarks -I../libegg -I.. -I/usr/include/mozilla-1.7.12/gtkembedmoz
-I/usr/include/mozilla-1.7.12 -I/usr/include/mozilla-1.7.12/xpcom
-I/usr/include/mozilla-1.7.12/string -I/usr/include/nspr4
-I/usr/include/mozilla-1.7.12 -I/usr/include/mozilla-1.7.12/caps
-I/usr/include/mozilla-1.7.12/chardet -I/usr/include/mozilla-1.7.12/content
-I/usr/include/mozilla-1.7.12/cookie -I/usr/include/mozilla-1.7.12/docshell
-I/usr/include/mozilla-1.7.12/dom -I/usr/include/mozilla-1.7.12/exthandler
-I/usr/include/mozilla-1.7.12/find -I/usr/include/mozilla-1.7.12/gfx
-I/usr/include/mozilla-1.7.12/helperAppDlg -I/usr/include/mozilla-1.7.12/history
-I/usr/include/mozilla-1.7.12/htmlparser -I/usr/include/mozilla-1.7.12/java
-I/usr/include/mozilla-1.7.12/js -I/usr/include/mozilla-1.7.12/jsconsole
-I/usr/include/mozilla-1.7.12/layout -I/usr/include/mozilla-1.7.12/locale
-I/usr/include/mozilla-1.7.12/mimetype -I/usr/include/mozilla-1.7.12/mozxfer
-I/usr/include/mozilla-1.7.12/necko -I/usr/include/mozilla-1.7.12/necko2
-I/usr/include/mozilla-1.7.12/nkcache -I/usr/include/mozilla-1.7.12/oji
-I/usr/include/mozilla-1.7.12/passwordmgr -I/usr/include/mozilla-1.7.12/pipnss
-I/usr/include/mozilla-1.7.12/pipboot -I/usr/include/mozilla-1.7.12/pref
-I/usr/include/mozilla-1.7.12/progressDlg -I/usr/include/mozilla-1.7.12/sidebar
-I/usr/include/mozilla-1.7.12/shistory -I/usr/include/mozilla-1.7.12/uconv
-I/usr/include/mozilla-1.7.12/uriloader
-I/usr/include/mozilla-1.7.12/unicharutil -I/usr/include/mozilla-1.7.12/wallet
-I/usr/include/mozilla-1.7.12/webbrowserpersist
-I/usr/include/mozilla-1.7.12/webbrwsr -I/usr/include/mozilla-1.7.12/webshell
-I/usr/include/mozilla-1.7.12/widget -I/usr/include/mozilla-1.7.12/windowwatcher
-I/usr/include/mozilla-1.7.12/xpconnect -DORBIT2=1 -pthread
-I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
-I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/libgnomeui-2.0
-I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include
-I/usr/include/gnome-keyring-1 -I/usr/include/orbit-2.0
-I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0
-I/usr/include/freetype2 -I/usr/include/libglade-2.0
-I/usr/include/gnome-vfs-module-2.0 -I/usr/include/gnome-desktop-2.0
-I/usr/include/startup-notification-1.0 -DLIB_DIR=\"/usr/lib/galeon\"
-DSHARE_DIR=\"/usr/share/galeon\"
-DGALEON_MOZILLA_HOME=\"/usr/lib/mozilla-1.7.12\" -D_GNU_SOURCE=1 -include
/usr/include/mozilla-1.7.12/mozilla-config.h -fno-rtti -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fshort-wchar -Wall
-Wsign-compare -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -MT
mozilla-embed-persist.lo -MD -MP -MF .deps/mozilla-embed-persist.Tpo -c
mozilla-embed-persist.cpp  -fPIC -DPIC -o .libs/mozilla-embed-persist.o
ProgressListener.h:88: error: extra qualification 'GProgressListener::' on
member 'OnProgressChange64'
make[2]: *** [mozilla-embed-persist.lo] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/galeon-2.0.0/mozilla'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/galeon-2.0.0'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.54859 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.54859 (%build)

This looks like a g++ issue. 

Full mock logs available on request.
Comment 1 Denis Leroy 2006-03-01 16:06:55 EST

*** This bug has been marked as a duplicate of 179783 ***

Note You need to log in before you can comment on or make changes to this bug.