Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1810202 - UPI documentation uses pip
Summary: UPI documentation uses pip
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.0
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
: 1809928 (view as bug list)
Depends On: 1810196
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 17:22 UTC by Pierre Prinetti
Modified: 2020-05-13 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Docs recommend using pip for installing UPI requirements Consequence: pip is not supported by Red Hat Fix: Change the docs so that they recommend installing Python modules from system packages Result: UPI requirements are installed in a supported workflow.
Clone Of: 1810196
Environment:
Last Closed: 2020-05-13 22:00:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3246 0 None closed [release-4.4] Bug 1810202: Use RPM for UPI dependencies 2020-04-17 13:16:47 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:00:34 UTC

Description Pierre Prinetti 2020-03-04 17:22:56 UTC
+++ This bug was initially created as a clone of Bug #1810196 +++

OpenShift on Openstack UPI documentation recommends pip for installing Python packages; however the use of pip is not supported by Red Hat.

Comment 1 Pierre Prinetti 2020-03-05 16:02:47 UTC
*** Bug 1809928 has been marked as a duplicate of this bug. ***

Comment 2 bart 2020-03-05 16:18:22 UTC
Maybe also add 
sudo alternatives --set python /usr/bin/python3

to be able to just call python. Some of the scripts on the install doc use them

Comment 3 Pierre Prinetti 2020-03-05 16:28:48 UTC
> Maybe also add

done, thanks! https://github.com/openshift/installer/pull/3234 (I will link the backport to this BZ)

Comment 6 David Sanz 2020-03-10 10:01:01 UTC
LGTM

Comment 8 errata-xmlrpc 2020-05-13 22:00:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.