Bug 1810248 - Nothing obseletes wxPython-devel
Summary: Nothing obseletes wxPython-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 19:34 UTC by Ian McInerney
Modified: 2020-03-16 20:34 UTC (History)
7 users (show)

Fixed In Version: fedora-obsolete-packages-32-38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-16 20:34:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Ian McInerney 2020-03-04 19:34:39 UTC
Description of problem:

Nothing is obsoleting the wxPython-devel retired package in F32, which means an F32 upgrade from F31 with wxPython-devel installed will give an error on dependency checking.



How reproducible: always



Steps to Reproduce:
Run the following on an F31 system with wxPython-devel installed:

sudo dnf module reset '*'

sudo dnf --releasever=32 --setopt=module_platform_id=platform:f32 \
    --enablerepo=updates-testing --enablerepo=updates-testing-modular \
    distro-sync



Actual results:

This error is shown:

Problem 5: package wxPython-devel-3.0.2.0-26.fc31.noarch requires python2-wxpython = 3.0.2.0-26.fc31, but none of the providers can be installed
  - python2-wxpython-3.0.2.0-26.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package wxPython-devel-3.0.2.0-26.fc31.noarch



Expected results:

No error


Additional info:

Is this supposed to be obsoleted by python3-wxpython4, or should it be added to fedora-obsolete-packages?

Comment 1 Scott Talbert 2020-03-04 19:41:26 UTC
Thanks for the report.  I think it should be in fedora-obsolete-packages since that's where the rest of python2-wxpython was obsoleted.  @Miro do you mind adding this one to f-o-p for F32+?

Comment 2 Scott Talbert 2020-03-04 20:50:31 UTC
I would do a pull request but f-o-p changes so often that PRs frequently require rebasing due to changelog merge conflicts.  :(  Will be nice if/when the changelog generation stuff happens.

Comment 3 Miro Hrončok 2020-03-04 23:29:50 UTC
Feel free to do changelog-less PRs.

Comment 4 Scott Talbert 2020-03-05 01:01:44 UTC
What's the preferred solution for f-o-p when changes needed to both F32 and master branches?  Do separate PR's for each branch?

Comment 5 Miro Hrončok 2020-03-05 09:15:26 UTC
The changelog-less commits are extremely easy to cherry-pick, so I don't have a preference.

Comment 6 Miro Hrončok 2020-03-05 17:36:50 UTC
On it now.

Comment 8 Fedora Update System 2020-03-05 19:36:47 UTC
fedora-obsolete-packages-32-38 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-14e988c430

Comment 9 Fedora Update System 2020-03-16 20:34:15 UTC
fedora-obsolete-packages-32-38 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.