Bug 1810252 - Operator Groups cannot be added to application groups
Summary: Operator Groups cannot be added to application groups
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On: 1806644
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 19:46 UTC by Jeff Phillips
Modified: 2020-05-13 22:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1806644
Environment:
Last Closed: 2020-05-13 22:00:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4632 0 None closed [release-4.4] Bug 1810252: Allow regrouping of operator groups and helm releases 2020-04-22 14:01:29 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:00:35 UTC

Description Jeff Phillips 2020-03-04 19:46:03 UTC
+++ This bug was initially created as a clone of Bug #1806644 +++

Description of problem:

In the topology view, the user should be able to add Operator Groups to application groups. Shift-click and drag on these items does not show the regrouping operation and dropping on an existing application group has no effect.


Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. Shift-drag an operator group from an application group to the graph
2. Shift-drag an operator group over an application group
3. right click on an operator group

Actual results:

The operator group is only moved, it is not (1) removed from its group (2) added to the target application group (3) nothing happens

Expected results:

(1) a popup should be shown to confirm removing from a group
(2) the operator group should be added to the application group (a confirm modal will show if the operator group already belongs to an application group)
(3) a context menu should appear allowing the user to edit the application group

Additional info:

--- Additional comment from Jeff Phillips on 2020-02-26 15:38:22 UTC ---

This is also a problem for Helm Releases. Same steps as above for them.

Comment 4 errata-xmlrpc 2020-05-13 22:00:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.