Bug 1810253 - Nothing obseletes exaile
Summary: Nothing obseletes exaile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 19:47 UTC by Ian McInerney
Modified: 2020-03-16 20:34 UTC (History)
6 users (show)

Fixed In Version: fedora-obsolete-packages-32-38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-16 20:34:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Ian McInerney 2020-03-04 19:47:49 UTC
Nothing is obsoleting the exaile retired package in F32, which means an F32 upgrade from F31 with exaile installed will give an error on dependency checking.



How reproducible: always



Steps to Reproduce:
Run the following on an F31 system with exaile installed:

sudo dnf module reset '*'

sudo dnf --releasever=32 --setopt=module_platform_id=platform:f32 \
    --enablerepo=updates-testing --enablerepo=updates-testing-modular \
    distro-sync



Actual results:

This error is shown:

Problem 2: package exaile-4.0.0-3.fc31.noarch requires python2-dbus, but none of the providers can be installed
  - python2-dbus-1.2.8-6.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package exaile-4.0.0-3.fc31.noarch



Expected results:

No error.



Additional info:

This package was retired due to the python2 retirement, so it should probably be added to fedora-obsolete-packages - unless the maintainer wants to re-add this (since it looks like upstream is compatible with Python3 - https://github.com/exaile/exaile/blob/master/DEPS).

Comment 1 Ian McInerney 2020-03-04 19:50:02 UTC
@miro adding you to CC so this can be obsoleted in fedora-obsolete-packages if needed.

Comment 2 Miro Hrončok 2020-03-04 23:24:55 UTC
$ repoquery --repo={fedora,updates{,-testing}} --releasever 32 --latest=1 --obsoletes fedora-obsolete-packages | grep exaile
exaile < 0.3.2.1-2


Seems like a version mismatch.

Comment 3 Miro Hrončok 2020-03-05 17:36:46 UTC
On it now.

Comment 5 Fedora Update System 2020-03-05 19:36:46 UTC
fedora-obsolete-packages-32-38 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-14e988c430

Comment 6 Fedora Update System 2020-03-16 20:34:13 UTC
fedora-obsolete-packages-32-38 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.