Bug 181026 - gnofract4d doesn't build under current devel/fc5 mock due to gcc issues
Summary: gnofract4d doesn't build under current devel/fc5 mock due to gcc issues
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnofract4d   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael J Knox
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-11 21:49 UTC by Kevin Fenzi
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 04:43:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Fenzi 2006-02-11 21:49:44 UTC
Description of problem:
gnofract4d doesn't build under current devel/fc5 mock due to gcc issues.

From the end of the mock build.log:

creating build/temp.linux-i686-2.4/fract4d
creating build/temp.linux-i686-2.4/fract4d/c
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -D_GNU_SOURCE -fPIC
-fPIC -D_REENTRANT=1 -UNDEBUG -Ifract4d/c -I/usr/include/python2.4 -c
fract4d/c/fract4dmodule.cpp -o
build/temp.linux-i686-2.4/fract4d/c/fract4dmodule.o -Wall
fract4d/c/fractFunc.h:120: error: extra qualification 'fractFunc::' on member
'clear_in_fates'
fract4d/c/fract4dmodule.cpp: In member function 'void FDSite::send(msg_t*)':
fract4d/c/fract4dmodule.cpp:626: warning: ignoring return value of 'ssize_t
write(int, const void*, size_t)', declared with attribute warn_unused_result
error: command 'gcc' failed with exit status 1
error: Bad exit status from /var/tmp/rpm-tmp.773 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.773 (%build)

Full mock build logs available on request.

Comment 1 Michael Schwendt 2006-03-03 13:04:10 UTC
Package has been without a maintainer for some time and has been removed
from the Fedora Extras Development repository. It won't reappear unless
somebody picks it up. For more information:

http://fedoraproject.org/wiki/Extras/OrphanedPackages
http://fedoraproject.org/wiki/Extras/FC5Status



Note You need to log in before you can comment on or make changes to this bug.