Bug 181028 - gnome-telnet doesn't build under current devel/fc5 mock due to missing BR
gnome-telnet doesn't build under current devel/fc5 mock due to missing BR
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-telnet (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-02-11 16:52 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-27 07:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-02-11 16:52:51 EST
Description of problem:
gnome-telnet doesn't build under current devel/fc5 mock due to missing BR.

From the end of the mock build.log: 

gcc  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -Wall -Wunused   -o gnome-telnet main.o support.o
interface.o -rdynamic -L/usr/lib -rdynamic -lgnomeui -lart_lgpl -lgdk_imlib -lSM
-lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd
-lasound -laudiofile -lm -lglib -rdynamic -lzvt -lutil -lSM -lICE -lgdk_imlib
-lgtk -lgdk -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm
/usr/bin/ld: cannot find -lSM
collect2: ld returned 1 exit status
make[2]: *** [gnome-telnet] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/gnome-telnet-2.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/gnome-telnet-2.5'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.30610 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.30610 (%build)

Possibly missing a BuildRequires for libSM-devel.
Comment 1 Michael Schwendt 2006-03-03 08:04:23 EST
Package has been without a maintainer for some time and has been removed
from the Fedora Extras Development repository. It won't reappear unless
somebody picks it up. For more information:

http://fedoraproject.org/wiki/Extras/OrphanedPackages
http://fedoraproject.org/wiki/Extras/FC5Status

Note You need to log in before you can comment on or make changes to this bug.