Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1810283 - Overriding Boolean ansible role variables does not work
Summary: Overriding Boolean ansible role variables does not work
Keywords:
Status: CLOSED DUPLICATE of bug 1785231
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Ansible
Version: 6.6.0
Hardware: All
OS: All
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 21:14 UTC by roarora
Modified: 2020-08-24 10:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-24 10:57:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description roarora 2020-03-04 21:14:29 UTC
Description of problem:

Overriding boolean variables imported from ansible roles does not seem to work when running ansible roles.

Version-Release number of selected component (if applicable):
6.6

How reproducible:
Always

Steps to Reproduce:
1. Import a role having boolean value true/false in defaults. example flag: true
2. Import the variables and override variable value. Example override flag to false
3. Assign the role to a host and run roles and notice the value is not overridden

For all non boolean overridden variables, the overridden value can be seen in dynflow task details under ansible_inventory json. But the boolean overridden variables never reach there and hence never makes to role execution.

Expected results:

Boolean vars overriding should work as other types work

Additional info:

Comment 4 Tomer Brisker 2020-08-24 10:57:08 UTC

*** This bug has been marked as a duplicate of bug 1785231 ***


Note You need to log in before you can comment on or make changes to this bug.