Bug 1810310 - 'oc adm release [info | extract | mirror] --help' Examples displayed incorrectly
Summary: 'oc adm release [info | extract | mirror] --help' Examples displayed incorrectly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jack Ottofaro
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 22:50 UTC by Jack Ottofaro
Modified: 2020-07-13 17:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
'oc adm release [info | extract | mirror] --help' examples have been fixed to display correctly.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:18:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 340 None closed Bug 1810310: fix examples in help 2020-06-30 18:02:09 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:18:34 UTC

Description Jack Ottofaro 2020-03-04 22:50:05 UTC
Description of problem:

Examples displayed as part of help for 'oc adm release [info | extract | mirror]  command is incorrect. For example:

$ oc adm release info --help
Show information about an OpenShift release...
...
Examples:
  # Show information about the cluster's current release
  %[1]s

should be displayed as:

$ oc adm release info --help
Show information about an OpenShift release...
...
Examples:
  # Show information about the cluster's current release
  oc adm release info


Expected results:


Additional info:

Comment 3 zhou ying 2020-03-09 06:59:31 UTC
Confirmed with latest oc client, can't reproduce the issue now: 

[yinzhou@localhost test]$  oc version -o yaml
clientVersion:
  buildDate: "2020-03-06T23:07:39Z"
  compiler: gc
  gitCommit: 8ce61268781d2074158d05ad11141792b94b1910
  gitTreeState: clean
  gitVersion: 4.5.0-202003062301-8ce6126
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64


[yinzhou@localhost test]$  oc adm release info --help
Show information about an OpenShift release

.....

Examples:
  # Show information about the cluster's current release
  oc adm release info
  
  # Show the source code that comprises a release
  oc adm release info 4.2.2 --commit-urls


[yinzhou@localhost test]$  oc adm release extract --help
Extract the contents of a release image to disk
....
Usage:
  oc adm release extract [flags]

Examples:
  # Use git to check out the source code for the current cluster release to DIR
  oc adm release extract --git=DIR


[yinzhou@localhost test]$  oc adm release mirror -h
Mirror an OpenShift release image to another registry

....
Usage:
  oc adm release mirror [flags]

Examples:
  # Perform a dry run showing what would be mirrored, including the mirror objects
  oc adm release mirror 4.2.2 --to myregistry.local/openshift/release --dry-run

Comment 5 errata-xmlrpc 2020-07-13 17:18:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.