Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1810320 - Cannot upgrade to Fedora 32
Summary: Cannot upgrade to Fedora 32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zypper
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1800295
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-04 23:42 UTC by dan.cermak
Modified: 2020-03-21 02:14 UTC (History)
2 users (show)

Fixed In Version: zypper-1.14.35-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-21 02:14:38 UTC
Type: Bug


Attachments (Terms of Use)

Description dan.cermak 2020-03-04 23:42:03 UTC
Description of problem: Zypper blocks the update to Fedora 32


Version-Release number of selected component (if applicable):
- zypper-1.14.33-1.fc31.x86_64
- zypper-log-1.14.32-1.fc32.noarch

How reproducible:
$ sudo dnf --releasever=32 --setopt=module_platform_id=platform:f32 --enablerepo=updates-testing --enablerepo=updates-testing-modular distro-sync
Last metadata expiration check: 0:08:03 ago on Thu 05 Mar 2020 12:26:02 AM CET.
Error:
 Problem 1: problem with installed package zypper-1.14.33-1.fc31.x86_64
  - zypper-1.14.33-1.fc31.x86_64 does not belong to a distupgrade repository
  - nothing provides libzypp.so.1712()(64bit) needed by zypper-1.14.32-1.fc32.x86_64
  - nothing provides libzypp.so.1712(ZYPP_plain)(64bit) needed by zypper-1.14.32-1.fc32.x86_64
 Problem 2: problem with installed package zypper-log-1.14.33-1.fc31.noarch
  - package zypper-log-1.14.32-1.fc32.noarch requires zypper = 1.14.32-1.fc32, but none of the providers can be installed
  - zypper-log-1.14.33-1.fc31.noarch does not belong to a distupgrade repository
  - nothing provides libzypp.so.1712()(64bit) needed by zypper-1.14.32-1.fc32.x86_64
  - nothing provides libzypp.so.1712(ZYPP_plain)(64bit) needed by zypper-1.14.32-1.fc32.x86_64
(try to add '--skip-broken' to skip uninstallable packages)


Steps to Reproduce:
1. sudo dnf module reset '*'
2. sudo dnf --releasever=32 --setopt=module_platform_id=platform:f32 --enablerepo=updates-testing --enablerepo=updates-testing-modular distro-sync


Actual results:
upgrade fails

Expected results:
upgrade succeeds

Additional info:
See Miroslav's email to devel "Donate 1 minute of your time to test upgrades from F31 to F32"

Comment 1 Neal Gompa 2020-03-08 02:51:56 UTC
Unfortunately, this is blocked on getting zypper to build on Fedora 32...

Comment 2 Fedora Update System 2020-03-20 14:07:22 UTC
FEDORA-2020-22b9976d8c has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-22b9976d8c

Comment 3 Fedora Update System 2020-03-21 02:14:38 UTC
libzypp-17.23.2-1.fc32, zypper-1.14.35-2.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.