Bug 1810379 - Delete vm template does not redirect to vmtemplates list
Summary: Delete vm template does not redirect to vmtemplates list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-05 06:09 UTC by Guohua Ouyang
Modified: 2020-07-13 17:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: VM-Template URL changed Consequence: Links does not link currectly Fix: Update links Result:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:18:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:18:44 UTC

Description Guohua Ouyang 2020-03-05 06:09:21 UTC
Description of problem:
Create two vm templates, go to one vm template detail page and delete it via action -> delete, it redirects to "k8s/ns/default/templates", not "k8s/ns/default/vmtemplates", the wizard button is not available on that page.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-03-02-011520

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tomas Jelinek 2020-03-05 09:33:54 UTC
this will not make 4.4 due to time, moving to 4.5.
@nelly, ack?

Comment 2 Nelly Credi 2020-03-05 13:38:45 UTC
ack

Comment 3 Guohua Ouyang 2020-03-31 03:27:07 UTC
The base URL is changing to "k8s/ns/default/virtualization", many places need to adjust accordingly.

Comment 4 Yaacov Zamir 2020-05-06 11:09:31 UTC
Submitted upstream:
https://github.com/openshift/console/pull/5303

Comment 5 Yaacov Zamir 2020-05-11 15:56:23 UTC
submited upstream:
https://github.com/openshift/console/pull/5388

Comment 6 Yaacov Zamir 2020-05-12 04:02:29 UTC
merged upstream:
https://github.com/openshift/console/pull/5388

Comment 9 Guohua Ouyang 2020-05-13 05:53:32 UTC
verified on 4.5.0-0.nightly-2020-05-12-065413.

Comment 11 errata-xmlrpc 2020-07-13 17:18:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.