Bug 1810437 - The visible cursor is not aligned with actual location in GNOME
Summary: The visible cursor is not aligned with actual location in GNOME
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 32
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-05 09:06 UTC by Ian Laurie
Modified: 2020-04-02 02:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-02 02:19:12 UTC
Type: Bug


Attachments (Terms of Use)
GNOME cursor offset at bottom right corner of a window. (284.77 KB, image/png)
2020-03-05 09:06 UTC, Ian Laurie
no flags Details

Description Ian Laurie 2020-03-05 09:06:11 UTC
Created attachment 1667686 [details]
GNOME cursor offset at bottom right corner of a window.

Description of problem:
The visible cursor is offset relative to the actual location in GNOME.  For example dragging window corners... top left and bottom left are correct, but top right has a horizontal displacement, and bottom right has a horizontal and vertical displacement (this is shown in the screen shot).

Version-Release number of selected component (if applicable):
gnome-shell-3.35.92-1.fc32.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log into GNOME.
2.
3.

Additional info:
The issue is very serious because in a text editor when you try and select text you end up selecting text from the line above.  Also in Nautilus if you have folders set to expandable it is difficult to click on the little expander icons due to the offset of the cursor.

I am using a virtual environment (VirtualBox).

I have this problem only in GNOME but I have it in Fedora 32 beta branch and also in Rawhide.  On Rawhide I have no problems in MATE or Xfce.

I do not have this issue in GNOME on Fedora 31, the problem seems unique to GNOME 3.35.x beta.

Comment 1 Ian Laurie 2020-03-05 09:36:11 UTC
I've narrowed this down to Wayland on GNOME 3.35.x beta.  On both Fedora 32 beta and Rawhide if I launch GNOME on Xorg I do not have this problem, it is only on Wayland.

However on Fedora 31 I do not have the problem on Xorg or Wayland.

Comment 2 Ian Laurie 2020-03-14 22:53:32 UTC
I still have this issue in Wayland on the released version gnome-shell-3.36.0-3.fc32.x86_64.

Comment 3 Ian Laurie 2020-04-01 23:58:54 UTC
I trashed my fc32 workstation beta image and remade it from Fedora-Everything-netinst-x86_64-32-20200330.n.1.iso and this problem is no longer reproducible.

Rawhide with all updates as of this moment still exhibits this problem.  

I think it would be beneficial to understand how system updates led to this problem, and further updated failed to fix it.  I will keep my problematic Rawhide workstation VirtualBox image in place in case someone has some ideas for things to try.  Meanwhile I will build a fresh Rawhide workstation image to see if that exhibits the problem, and will report my results.

Comment 4 Ian Laurie 2020-04-02 02:19:12 UTC
A new Rawhide workstation installation built from Fedora-Everything-netinst-x86_64-Rawhide-20200330.n.1.iso also does not exhibit this problem.

I'll code off this bug because it isn't reproducible on clean new installations.


Note You need to log in before you can comment on or make changes to this bug.