Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1810479 - VM vCPU is doubled after VM is created
Summary: VM vCPU is doubled after VM is created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Filip Krepinsky
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On: 1810372
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-05 10:44 UTC by Filip Krepinsky
Modified: 2020-05-13 22:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: VM template sockets were not reflected in the final VM created by the wizard Consequence: VM vCPU was doubled/.. after VM is created Fix: VM template sockets/cores/thread are reflected when creating a VM. Result: numberof vCPUs is correct
Clone Of: 1810372
Environment:
Last Closed: 2020-05-13 22:00:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4671 0 None closed [release-4.4] Bug 1810479: fix wrong sockets/threads when using Custom flavor 2020-04-20 10:31:15 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:00:50 UTC

Description Filip Krepinsky 2020-03-05 10:44:37 UTC
+++ This bug was initially created as a clone of Bug #1810372 +++

Description of problem:
Create a VM with custom vCPUs, after the VM or VM template is created, the vCPUs are doubled in detail page. It may caused by the CPU sockets are 2.

Edit the flavor and save, it shows the same value which is just inputed and the cpu socket changes to 1.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-03-02-011520

How reproducible:
100%

Steps to Reproduce:
1. Create a VM with custom flavor.
2. Verify CPU in detail page.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Guohua Ouyang 2020-03-12 02:10:49 UTC
verified on 4.4.0-0.nightly-2020-03-06-170328.

Comment 5 errata-xmlrpc 2020-05-13 22:00:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.