Bug 1810532 - Topology filter by application throws an error when it has Operator backed nodes
Summary: Topology filter by application throws an error when it has Operator backed nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Karthik Jeeyar
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On:
Blocks: 1810534
TreeView+ depends on / blocked
 
Reported: 2020-03-05 12:54 UTC by Karthik Jeeyar
Modified: 2020-08-04 18:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Filtering the OBS nodes based on the application in topology model is missing Consequence: Filtering the topology nodes by application, throws an error when the topology has operator backed services in the namespace. Fix: Add a logic to filter the OBS nodes based on the selected application group. Result: User can now filter the Operator backed service nodes based on the application.
Clone Of:
: 1810534 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:03:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
Topolgoy breaks when OBS nodes are in the canvas (589.40 KB, image/gif)
2020-03-05 12:57 UTC, Karthik Jeeyar
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4656 None closed Bug 1810532: Fix OBS filter by application issue [openshift-4.5] 2020-06-23 09:02:15 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:03:53 UTC

Description Karthik Jeeyar 2020-03-05 12:54:16 UTC
Description of problem:
Filtering the topology nodes by application, throws an error when the topology has operator backed services in the namespace.



Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to reproduce:
1. Install an operator and create a CRD instance using dev catalog flow
2. Create an node from git flow
3. Use the application selector to filter the node by application

Actual results:
It breaks the UI 

Expected results:
 It should filter the nodes based on the application and should not break the UI

Additional info:

Comment 1 Karthik Jeeyar 2020-03-05 12:57:44 UTC
Created attachment 1667741 [details]
Topolgoy breaks when OBS nodes are in the canvas

Comment 5 Jaivardhan Kumar 2020-03-06 07:33:30 UTC
Verified on 4.5

OpenShift Version
4.5.0-0.ci-2020-03-05-232742
Kubernetes Version
v1.17.1
Channel
stable-4.4
Cluster ID
0f33addf-9591-4d52-8e01-1b26e6ebd56a
API Server
https://api.gamore45installer0603.devcluster.openshift.com:6443

Comment 7 errata-xmlrpc 2020-08-04 18:03:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.