Bug 181055 - rfe: find duplicate packages
rfe: find duplicate packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-12 07:55 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 08:42:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-02-12 07:55:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060205 Epiphany/1.9.6

Description of problem:
If yum gets interrupted during an update of a package, it may not call cleanup.

It would be good to have a yum util that checks for dupes of packages.

e.g. find these:
$ rpm -q vixie-cron
vixie-cron-4.1-42.FC5
vixie-cron-4.1-44.FC5

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Seth Vidal 2006-02-24 11:39:04 EST
We're working on various ways to avoid this problem but in the meantime would it
be reasonable for this feature to be in the package-cleanup script in yum-utils?
Comment 2 Need Real Name 2006-02-24 12:15:49 EST
That would be great!
Comment 3 Seth Vidal 2006-02-24 16:32:53 EST
okay I added package-cleanup --dupes

it will sort the rpmdb and produce the lists it ignores:

1. kernels b/c they can have dupes
2. gpg-pubkey 'packages' for obvious reasons
3. multilib 'duplicates'

it will print out anything else. It up to the user to figure out which one they
want to remove (though they should probably remove both and reinstall one of them)
Comment 4 Need Real Name 2006-03-06 13:39:50 EST
Can you tell me which version this will be in?
I'm using rawhide version yum-utils-0.5-1.
Comment 5 Seth Vidal 2006-03-07 01:25:13 EST
it'll be in 0.6.

hopefully I'll push that out in a few days.


Note You need to log in before you can comment on or make changes to this bug.