Bug 1810568 - Using the Tab key to navigate around brings up Notification Drawer
Summary: Using the Tab key to navigate around brings up Notification Drawer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-05 14:13 UTC by Jeff Phillips
Modified: 2020-08-04 18:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: usability issue causes drawers to open using tab key Consequence: unwanted drawers open when using tab Fix: css fix to keep drawer hidden when closed Result: drawers to operate properly and stay closed when the user tabs around the application
Clone Of:
Environment:
Version: 4.4.0-0.nightly-2020-03-05-014624 Cluster ID: 714860d8-af7b-4390-9294-ba71303cf80b Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36
Last Closed: 2020-08-04 18:03:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
incorrect display of notification drawer (361.27 KB, image/png)
2020-03-05 14:13 UTC, Jeff Phillips
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5577 None closed Bug 1810568: fix for opening drawer when tabbing through page components (CSS only fix) 2020-08-13 08:40:20 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:03:52 UTC

Description Jeff Phillips 2020-03-05 14:13:08 UTC
Created attachment 1667771 [details]
incorrect display of notification drawer

Description of problem:

If I use the <tab> key to navigate through the UI, eventually it causes the notification drawer to be shown. The display is not quite right as the main areas is shifted to the left. Clicking on the masthead to open the notification drawer then fixes the display but leaves the drawer open.

See attachment

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. From anywhere in the UI, hit the tab key repeatedly trying to get back to where you started

Actual results:

The notification drawer is displayed and display is incorrect.

Expected results:

The UI focus should get back to the original focus component w/o displaying the notification drawer.

Additional info:

Comment 2 cvogt 2020-03-05 18:14:32 UTC
Once the drawer is opened in this way, the drawer remains opened until the user clicks the notification button in the header twice (open -> close). Or the user refreshed the browser.

Comment 3 Joe Caiani 2020-05-08 16:55:52 UTC
moving to upcoming sprint: issue has been raised in the pf drawer component. will update the component when it is addressed upstream.

Comment 5 bpeterse 2020-05-26 15:19:48 UTC
Bumping to 4.6.

Comment 6 Joe Caiani 2020-05-29 17:27:32 UTC
pr merged, and waiting on qa verification should be complete by next spring.

Comment 9 Yadan Pei 2020-06-03 08:07:50 UTC
Open Home -> Dashboards page, use Tab key to navigate throughout console, going next/back will not open notification drawer 

This is verified on 4.5.0-0.nightly-2020-06-02-174025 & Chrome 85

Comment 10 Yadan Pei 2020-06-03 08:08:12 UTC
sorry it should be Chrome 83

Comment 12 errata-xmlrpc 2020-08-04 18:03:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.