Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1810635 - GCP UPI does not support networks outside of target project
Summary: GCP UPI does not support networks outside of target project
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.z
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Abhinav Dahiya
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-05 16:05 UTC by Antonio Escalera
Modified: 2020-03-17 02:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-05 17:05:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Antonio Escalera 2020-03-05 16:05:39 UTC
Description of problem:

In GCP, it is common to have one project with all of the networks, and share them to VPCs in other projects. 
UPI with this topology currently fails when creating manifests.
We need to be able to support shared VPC networking, as this is the current best practices recommendation from Google.

https://cloud.google.com/vpc/docs/shared-vpc#shared_vpc_networks

Version:
4.3.2

How reproducible:

100%

Steps to Reproduce:
1. Create project with networks
2. Share networks to VPC in different project
3. Try to run the OpenShift installer in that different project

Actual results:

$ openshift-install create manifests
FATAL failed to fetch Master Machines: failed to load asset "Install Config": platform.gcp.network: Invalid value: "paas-ops-01": failed to get network paas-ops-01: Get https://www.googleapis.com/compute/v1/projects/xxxxx-paas-ops/global/networks/paas-ops-01?alt=json&prettyPrint=false: context canceled

Expected results:

Manifests are created successfully

Additional info:

Comment 1 Abhinav Dahiya 2020-03-05 17:05:30 UTC
We don't support Shared VPC. This is not a bug.

Please open a RFE https://issues.redhat.com/secure/RapidBoard.jspa?rapidView=5496&view=detail


Note You need to log in before you can comment on or make changes to this bug.