Bug 1810723 - The disaster recovery scripts need simplification
Summary: The disaster recovery scripts need simplification
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1810469
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-05 19:19 UTC by Suresh Kolichala
Modified: 2020-05-04 11:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1810469
Environment:
Last Closed: 2020-05-04 11:45:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 241 0 None open [release-4.4] Bug 1810723: The disaster recovery scripts need simplification 2020-03-06 16:18:47 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:45:22 UTC

Description Suresh Kolichala 2020-03-05 19:19:03 UTC
+++ This bug was initially created as a clone of Bug #1810469 +++

Description of problem:
With the introduction of cluster-etcd-operator, much of the functionality in the old DR scripts is no longer needed. Therefore the scripts needed to be trimmed down and simplified.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Expected to work in the same manner as current scripts.

Expected results:


Additional info:
Simplification of the existing scripts.

Comment 3 ge liu 2020-03-08 07:53:48 UTC
Yes, it kept etcd backup and restore script, and whole restore process is simpler than old design from 4.1 to 4.3. it's amazing progress.

Comment 5 errata-xmlrpc 2020-05-04 11:45:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.