Bug 18108 - dns lookup segfaults when duplicate entry in /etc/hosts
Summary: dns lookup segfaults when duplicate entry in /etc/hosts
Status: CLOSED DUPLICATE of bug 17832
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-02 16:41 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 16:41:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-02 16:41:22 UTC
I had the following problem which caused ping and other applications
to segfault. I believe the problem is in bind-utils.

In /etc/hosts a line was accidentally repeated.

192.168.29.5 linfoo.eink.com linfoo
...
192.168.29.5 linfoo.eink.com linfoo


Accessing all others hosts worked fine, but
linfoo could not be looked up by domain name.

"ping linfoo" and "resolveip linfoo" resulted in a segfault error.

I recently upgraded my installation from Redhat-6.2 to Redhat-7.0

Comment 1 Alan Cox 2000-10-02 16:47:53 UTC

*** This bug has been marked as a duplicate of 17832 ***


Note You need to log in before you can comment on or make changes to this bug.