Bug 1810832 - rpm: enable ndb
Summary: rpm: enable ndb
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rpm
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: swm-qe
URL:
Whiteboard:
Depends On: 1766120
Blocks: 1817010
TreeView+ depends on / blocked
 
Reported: 2020-03-06 00:28 UTC by Carl George 🤠
Modified: 2020-05-23 20:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1817010 (view as bug list)
Environment:
Last Closed: 2020-04-15 12:25:35 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Carl George 🤠 2020-03-06 00:28:58 UTC
Description of problem:
rpm in CentOS is currently built without ndb support.  Community members are interested in enabling this in CentOS Stream.

https://git.centos.org/rpms/rpm/pull-request/1

Version-Release number of selected component (if applicable):
rpm-4.14.2-36.el8

Additional info:
If this is determined to be acceptable, I'll attach a patch here from that pull request.

Comment 2 Davide Cavalca 2020-03-10 23:16:34 UTC
We (Facebook) have currently deployed ndb fleetwide on CentOS 7, and would like to be able to do the same on CentOS Stream. Enabling ndb support in rpm won't take effect unless one sets the %_db_backend ndb macro, so it should be safe (and a noop for existing systems).

Comment 3 Panu Matilainen 2020-03-13 13:17:45 UTC
Enabling ndb support in RHEL would require much more than just flicking a configure switch, such a thing would need to go through the official enhancement request process.

We can and should fix the spec thinko/typo that prevents "--with ndb" build option from working as intended though, starting with Fedora. So ACK for this commit https://git.centos.org/fork/malmond/rpms/rpm/c/d9949767ee5198b0fdbf2f527a385ce02532181a but NAK for actually enabling it.

Comment 4 Panu Matilainen 2020-04-15 12:25:35 UTC
Closing as WONTFIX per comment #3, the with/without typo is being handled separately through bug 1770972.

Comment 5 Carl George 🤠 2020-04-15 14:10:16 UTC
I believe the typo fix is being handled in bug 1817010, not but 1770972.

Comment 6 Panu Matilainen 2020-04-15 14:11:25 UTC
Oops, that's correct. Sorry (too much bug number copy-paste here for one afternoon)


Note You need to log in before you can comment on or make changes to this bug.