Bug 1810855 - unable to set mountpoint with the latest blivet-gui
Summary: unable to set mountpoint with the latest blivet-gui
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1814459 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-06 03:29 UTC by lnie
Modified: 2020-04-03 00:51 UTC (History)
3 users (show)

Fixed In Version: blivet-gui-2.1.12-3.fc32 blivet-gui-2.1.13-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-18 08:09:12 UTC
Type: Bug


Attachments (Terms of Use)
anaconda.log (9.68 KB, text/plain)
2020-03-06 03:29 UTC, lnie
no flags Details
storage.log (27.36 KB, text/plain)
2020-03-06 03:30 UTC, lnie
no flags Details

Description lnie 2020-03-06 03:29:25 UTC
Created attachment 1667979 [details]
anaconda.log

Description of problem:
Boot the installer,click into blivet-gui,create a partition,then try to set a different mountpoint(or none),but failed.
I have tried  debug the problem.
the run() function in MountpointDialog successfully pass the right mountpoint to 
ProxyDataContainer,but the user_input.mountpoint got by blivetgui.blivetgui is the old mountpoint,so I guess the problem happens during the communication?

Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-32-20200304.n.0.iso

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2020-03-06 03:30:18 UTC
Created attachment 1667980 [details]
storage.log

Comment 2 lnie 2020-03-06 04:37:48 UTC
Forget to mention,you can reset the mountpoint by 'format'

Comment 4 Fedora Update System 2020-03-11 09:57:58 UTC
FEDORA-2020-32ec868d12 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-32ec868d12

Comment 5 Fedora Update System 2020-03-12 10:02:40 UTC
FEDORA-2020-a51ca0bf96 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a51ca0bf96

Comment 6 Fedora Update System 2020-03-12 18:50:07 UTC
blivet-gui-2.1.12-3.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a51ca0bf96

Comment 7 Vojtech Trefny 2020-03-18 07:56:55 UTC
*** Bug 1814459 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2020-03-24 17:49:42 UTC
FEDORA-2020-a51ca0bf96 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2020-04-02 10:40:45 UTC
FEDORA-2020-576bd54f42 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-576bd54f42

Comment 10 Fedora Update System 2020-04-03 00:51:34 UTC
FEDORA-2020-576bd54f42 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.