Bug 1810907 - upgrade to F32 changes the default image viewer from eog to gimp
Summary: upgrade to F32 changes the default image viewer from eog to gimp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shared-mime-info
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-03-06 07:53 UTC by Kamil Páral
Modified: 2020-03-16 23:12 UTC (History)
14 users (show)

Fixed In Version: shared-mime-info-1.15-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-10 01:56:28 UTC
Type: Bug
kparal: fedora_prioritized_bug?


Attachments (Terms of Use)
default applications in F31 (before upgrade) (36.86 KB, image/png)
2020-03-06 07:54 UTC, Kamil Páral
no flags Details
default applications in F32 (after upgrade) (57.59 KB, image/png)
2020-03-06 07:55 UTC, Kamil Páral
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-control-center issues 900 None None None 2020-03-06 08:03:10 UTC

Description Kamil Páral 2020-03-06 07:53:52 UTC
Description of problem:
If you install GIMP in Fedora 31 (this doesn't change the default image viewer, so all pictures are by default still opened with "Image Viewer" - eog), and then upgrade to Fedora 32, the default image viewer changes to GIMP. So all pictures (png, jpg) that you click on in Nautilus get opened by GIMP. You have to go to gnome-control-center -> Default applications and change the default application back to Image Viewer, or you need to change the default association for each affected file type (mime type) using Nautilus' "Open With" dialog.


Version-Release number of selected component (if applicable):
Fedora 31:
eog-3.34.2-1.fc31.x86_64
gimp-2.10.18-1.fc31.x86_64
gnome-control-center-3.34.4-1.fc31.x86_64
nautilus-3.34.2-2.fc31.x86_64
shared-mime-info-1.15-1.fc31.x86_64

Fedora 32:
eog-3.35.92-1.fc32.x86_64
gimp-2.10.18-1.fc32.x86_64
gnome-control-center-3.35.92-1.fc32.x86_64
nautilus-3.35.92-1.fc32.x86_64
shared-mime-info-1.15-2.fc32.x86_64


How reproducible:
always

Steps to Reproduce:
1. install a clean F31 (or use some existing one where you haven't modified the default image viewer)
2. install GIMP (due to modularity issues still being unresolved during system upgrade, this is easier to do with "dnf install gimp --disablerepo=\*-modular")
3. open gnome-control-center -> Default applications and check that Image Viewer is still the selected option for "Photos"
4. check that .jpg and .png files open with Image Viewer (eog), when double clicked from Nautilus
5. upgrade to Fedora 32
6. see that .jpg and .png files are opened by GIMP when double clicked from Nautilus
7. open gnome-control-center -> Default applications and see that GIMP is the selected option for "Photos"


Actual results:
upgrade changes the default image viewer application to GIMP

Expected results:
upgrade doesn't change the default image viewer application

Comment 1 Kamil Páral 2020-03-06 07:54:42 UTC
Created attachment 1668014 [details]
default applications in F31 (before upgrade)

Comment 2 Kamil Páral 2020-03-06 07:55:02 UTC
Created attachment 1668015 [details]
default applications in F32 (after upgrade)

Comment 3 Kamil Páral 2020-03-06 08:03:11 UTC
I don't think this can be a release blocker, but GIMP is likely installed on many many Fedora systems, so this is likely to affect a large portion of our user base. Not everyone will know how to change the defaults back to Image Viewer. Marking as CommonBugs and also proposing as a PrioritizedBug. It would be very helpful to have this fixed before Fedora 32 public release.

Reported downstream here:
https://gitlab.gnome.org/GNOME/gnome-control-center/issues/900

Comment 4 Kalev Lember 2020-03-08 12:31:30 UTC
This was shared-mime-info needing an update after eog desktop file rename during the 3.35 development cycle. hadess fixed it in shared-mime-info-1.15-3.fc32

Comment 5 Fedora Update System 2020-03-08 12:31:56 UTC
FEDORA-2020-33fe031ad8 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-33fe031ad8

Comment 6 Kalev Lember 2020-03-08 12:33:49 UTC
Proposing as a F32 Beta Freeze Exception for some additional polish.

Comment 7 Fedora Update System 2020-03-08 17:15:41 UTC
shared-mime-info-1.15-3.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-33fe031ad8

Comment 8 Kamil Páral 2020-03-09 15:46:44 UTC
I can confirm the new package fixes the problem and EOG is still the default image viewer even after upgrade.

Comment 9 Adam Williamson 2020-03-09 17:41:44 UTC
I got *wine* as my new default image viewer. erp.

Comment 10 Geoffrey Marr 2020-03-10 01:03:21 UTC
Discussed during the 2020-03-09 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as it is a noticeable issue that cannot be fixed with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-09/f32-blocker-review.2020-03-09-16.01.txt

Comment 11 Fedora Update System 2020-03-10 01:56:28 UTC
shared-mime-info-1.15-3.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Adam Williamson 2020-03-16 23:12:59 UTC
dropping commonbugs nomination as this got fixed.


Note You need to log in before you can comment on or make changes to this bug.