Bug 1810954 - When upgrading to alsa 1.2.2 internal microphone not working anymore.
Summary: When upgrading to alsa 1.2.2 internal microphone not working anymore.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-06 09:48 UTC by René Perdok
Modified: 2020-03-19 01:44 UTC (History)
5 users (show)

Fixed In Version: pulseaudio-13.99.1-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-19 01:44:00 UTC
Type: Bug


Attachments (Terms of Use)
output from alsa-info.sh --no-upload (43.96 KB, text/plain)
2020-03-06 10:21 UTC, René Perdok
no flags Details

Description René Perdok 2020-03-06 09:48:52 UTC
Description of problem:
When I upgrade from alsa 1.1.9 release 2.fc31 to alsa 1.2.2 release 1.fc31 the internal microphone of my Dell XPS 13 is no longer detected. When I downgrade to 1.1.9 it is working again.


Version-Release number of selected component (if applicable):
alsa-lib-1.2.2-1.fc31.x86_64
alsa-lib-1.2.2-1.fc31.i686
alsa-plugins-pulseaudio-1.2.2-1.fc31.x86_64
alsa-ucm-1.2.2-1.fc31.noarch
alsa-utils-1.2.2-1.fc31.x86_64


How reproducible:
Install upgrade packages -> microphone not detected
Downgrade to 1.1.9 -> microphone is detected again


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jaroslav Kysela 2020-03-06 09:56:01 UTC
Please, attach output from 'alsa-info.sh --no-upload' and 'pactl list sources' for 1.2.2.

Comment 2 René Perdok 2020-03-06 10:18:13 UTC
Update on the issue: Yesterday it worked after downgrading, but today that did not fix the problem. So I am not sure if the cause is in alsa.

Comment 3 René Perdok 2020-03-06 10:19:43 UTC
[rene@laptoprp ~]$ pactl list sources
Source #1
	State: SUSPENDED
	Name: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
	Description: Monitor of Built-in Audio Analog Stereo
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 48000Hz
	Channel Map: front-left,front-right
	Owner Module: 22
	Mute: no
	Volume: front-left: 55040 /  84% / -4,55 dB,   front-right: 55040 /  84% / -4,55 dB
	        balance 0,00
	Base Volume: 65536 / 100% / 0,00 dB
	Monitor of Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
	Latency: 0 usec, configured 0 usec
	Flags: DECIBEL_VOLUME LATENCY 
	Properties:
		device.description = "Monitor of Built-in Audio Analog Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xdc518000 irq 161"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9dc8"
		device.product.name = "Cannon Point-LP High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Formats:
		pcm

Comment 4 René Perdok 2020-03-06 10:21:20 UTC
Created attachment 1668064 [details]
output from alsa-info.sh --no-upload

as requested, the output of alsa-info.sh --no-upload

Comment 5 Jaroslav Kysela 2020-03-06 10:42:23 UTC
Could you try to downgrade pulseaudio instead? I think it's problem with the latest PA change.

PA udev:

  +# Carbon X1
  ++SUBSYSTEMS=="pci", ATTRS{vendor}=="0x8086", ATTRS{device}=="0x9dc8", ENV{PULSE_PROFILE_SET}="sof-hda-dsp-dmic4.conf"

This machine is also:

  00:1f.3 0403: 8086:9dc8 (rev 30) (prog-if 80)

My original .rpm / tar ball for X1 was only hack, Wim.

Comment 6 René Perdok 2020-03-06 10:47:52 UTC
Thad indeed fixed the problem, so it was not alsa but pulseaudio! I wil post a bug for pulseaudio.

Thanks for the quick response and help Wim!

Comment 7 Jaroslav Kysela 2020-03-06 11:51:24 UTC
I already reassigned this bug to pulseaudio, it's not required to create a new one. Thank you for feedback.

Comment 8 Fedora Update System 2020-03-09 20:34:53 UTC
pulseaudio-13.99.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c3e19f5098

Comment 9 Fedora Update System 2020-03-19 01:44:00 UTC
pulseaudio-13.99.1-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.