Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1811003 - OCS installation should not proceed when storageclass is not selected in OCP >= v4.3.2
Summary: OCS installation should not proceed when storageclass is not selected in OCP ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: afrahman
QA Contact: Itzhak
URL:
Whiteboard:
: 1810031 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-06 11:56 UTC by Pratik Surve
Modified: 2020-07-13 17:19 UTC (History)
8 users (show)

Fixed In Version: 4.5
Doc Type: Enhancement
Doc Text:
Feature: If no storage class is selected at the time of installation, an error will be thrown and installation will not proceed Reason: The storage class selection is required since 4.3 and hence it should be selected before proceeding for installation. Result: When storage class is not selected , installation will not proceed and user will see an error on UI
Clone Of:
Environment:
Last Closed: 2020-07-13 17:18:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
OCS installation doesn't proceed without providing SC (35.00 KB, image/png)
2020-06-23 12:37 UTC, Itzhak
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5071 0 None closed Bug 1811003: Make storage class dropdown required 2020-06-22 06:15:30 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:19:10 UTC

Comment 4 afrahman 2020-03-06 13:11:45 UTC
I think this should be validated in backend.

Comment 6 afrahman 2020-03-06 13:26:17 UTC
Do you have a default storage class in your system ?
Ideally the default storage class is show in the dropdown if present

Comment 8 afrahman 2020-03-06 13:55:15 UTC
Thats with the flow then. We are using generic OCP component, which shows default storage class as first selected class , if present.
Otherwise one will see this.

Comment 9 Nishanth Thomas 2020-03-06 18:06:00 UTC
Very unlikely that customer run into this in normal cases. We will add some validation(either in UI or operator) but not a blocker for 4.3
Moving out of 4.3

Comment 10 afrahman 2020-03-17 08:06:47 UTC
It requires change in a console component hence we will take this as an enhancement for OCP 4.5 as thats the window we have available.

Comment 11 afrahman 2020-03-20 07:58:30 UTC
*** Bug 1810031 has been marked as a duplicate of this bug. ***

Comment 14 Itzhak 2020-06-23 12:35:49 UTC
I performed the following steps to reproduce the bug:

1. Navigate to Installed Operators -> OpenShift Container Storage -> Storage Gluster
2. Clicking on the add capacity button. 
3. In the storage class field choosing the "No default storage class" option and clicking
on the "Add" button. 

The result:
The installation didn't proceed, and it returned an error: "No StorageClass selected".

Versions I used to check the bug: 

OCP version:
Client Version: 4.3.8
Server Version: 4.5.0-0.nightly-2020-06-23-035950
Kubernetes Version: v1.18.3+c44581d

OCS verison:
ocs-operator.v4.5.0-460.ci   OpenShift Container Storage   4.5.0-460.ci                         Succeeded

cluster version
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-06-23-035950   True        False         3h51m   Cluster version is 4.5.0-0.nightly-2020-06-23-035950

Rook version
rook: 4.5-27.acf5b22b.release_4.5
go: go1.13.4

Ceph version
ceph version 14.2.8-59.el8cp (53387608e81e6aa2487c952a604db06faa5b2cd0) nautilus (stable)

Comment 15 Itzhak 2020-06-23 12:37:21 UTC
Created attachment 1698448 [details]
OCS installation doesn't proceed without providing SC

Comment 17 errata-xmlrpc 2020-07-13 17:18:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.