Bug 1811088 - [4.4] CSI certification tests count success as failures
Summary: [4.4] CSI certification tests count success as failures
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Jan Safranek
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On: 1811020
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-06 15:01 UTC by Jan Safranek
Modified: 2020-05-04 11:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1811020
Environment:
Last Closed: 2020-05-04 11:45:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 24648 0 None closed [4.4]: Bug 1811088: Fix count of failures in JUnit output 2020-09-20 03:27:17 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:45:29 UTC

Description Jan Safranek 2020-03-06 15:01:27 UTC
+++ This bug was initially created as a clone of Bug #1811020 +++

Description of problem:

JUinit output of our csi certification suite counts successful tests as failures.

stdout from the openshift-tests container
43 pass, 106 skip (9m11s)

JUnit output:
<testsuite name="openshift-tests" tests="106" skipped="106" failures="43" time="551">

(failures="43" is wrong, it's nr. of successes)


Version-Release number of selected component (if applicable):
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:376b0eafdbba3c238c214355850a3387a444b10bd651eb1c7bf3efda753689c4


How reproducible:
always

Steps to Reproduce:
See result of any pull-ci-openshift-origin-master-e2e-aws-csi job in CI, for example: https://storage.googleapis.com/origin-ci-test/pr-logs/pull/24627/pull-ci-openshift-origin-master-e2e-aws-csi/178/artifacts/e2e-aws-csi/junit/junit_e2e_20200305-211409.xml

Actual results:
The tests passed, but records "44" failures in JUnit XML:

<testsuite name="openshift-tests" tests="107" skipped="106" failures="44" time="388">


Expected results:
failures="0" (on a successful test run)

Comment 5 errata-xmlrpc 2020-05-04 11:45:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.