Bug 1811143 - upgrades where entire sample imagestreams were removed in the new version can get stuck in progressing
Summary: upgrades where entire sample imagestreams were removed in the new version can...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks: 1811204
TreeView+ depends on / blocked
 
Reported: 2020-03-06 17:25 UTC by Gabe Montero
Modified: 2020-07-13 17:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: if a sample imagestream available in a prior release was removed in a subsequent release, then during upgrade to that subsequent release the removed imagestream could be incorrectly tracked as needing imagestreamimports to complete, and since no imagestreamimmports are even occurring, samples will not report its upgrade as complete Consequence: overall upgraded would be marked as failed if the problematic timing windows in samples operator occured Fix: samples operated was updated to not attempt to track imagestreams which existed in a prior release but not in the release we are upgrading to Result: imagestreams that are removed release to release should not cause samples operator to fail upgrade
Clone Of:
: 1811204 1811206 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:18:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 240 None closed Bug 1811143: purge removed imagestreams as a part of upgrade from progessing/impor… 2020-07-14 10:12:21 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:19:27 UTC

Description Gabe Montero 2020-03-06 17:25:12 UTC
See my analysis in https://github.com/openshift/cincinnati-graph-data/pull/99 for 4.3.5

Comment 10 XiuJuan Wang 2020-03-16 12:10:01 UTC
Gabe thanks

I tried to upgrade from 4.2.23 to 4.3,don't met the bug issue. I must have missed the chance to reproduce it as you said.

Upgrade from 4.4.0-rc.0 to 4.5.0-0.nightly-2020-03-16-004817 successfully, we are good to mark this bug to verified.

Comment 11 W. Trevor King 2020-04-28 21:03:24 UTC
Cross-linking bug 1828065, which is also about 4.5 samples Progessing.

Comment 13 errata-xmlrpc 2020-07-13 17:18:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.