Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1811185 - Topology Visualization is not viewable for view only users.
Summary: Topology Visualization is not viewable for view only users.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks: 1811275
TreeView+ depends on / blocked
 
Reported: 2020-03-06 19:07 UTC by Jeff Phillips
Modified: 2020-07-13 17:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1811275 (view as bug list)
Environment:
Version: 4.5.0-0.ci-2020-03-06-100746 Cluster ID: 539a5e69-44c1-4c62-bea1-a416d6fb35fc Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.132 Safari/537.36
Last Closed: 2020-07-13 17:18:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4677 0 None closed Bug 1811185: Allow users with view only privs access to topology 2020-04-28 20:24:40 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:19:27 UTC

Description Jeff Phillips 2020-03-06 19:07:33 UTC
Description of problem:

For the users with the view only permission is not able to view the topology Visualization due to fetching of secrets which is not allowed for a `view` cluster role.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a user with `view` only cluster role
2. Visit Topology page

Actual results:

Instead of showing visualization, the topology page shows the restricted access error.


Expected results:

If the user have view only permission clusterwide or in a particular namespace, then they must see the visualization while visiting topology page.


Additional info:

Comment 3 Karthik Jeeyar 2020-03-09 14:55:22 UTC
Able to see the topology visualization with limited view permissions. Verified on
Build number : 4.5.0-0.ci-2020-03-09-035935
Cluster Url :https://console-openshift-console.apps.sp89.devcluster.openshift.com/topology/ns/jeff-project/graph
Browsers : chrome Version 79 , firefox - 66.0.2
Verified as : kubeadmin and test (only view access)

Comment 5 errata-xmlrpc 2020-07-13 17:18:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.