Bug 1811242 - anaconda does not read storage information from kickstart
Summary: anaconda does not read storage information from kickstart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1820771 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-06 23:15 UTC by louisgtwo
Modified: 2020-04-09 15:36 UTC (History)
8 users (show)

Fixed In Version: anaconda-32.24.3-1 anaconda-32.24.3-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-22 03:08:58 UTC
Type: Bug


Attachments (Terms of Use)

Description louisgtwo 2020-03-06 23:15:43 UTC
fedora 32 anaconda freezes on probing storage when performing a kickstart install. If I comment out the disk info in my kickstart file the install runs fine I just have to manually configure my disk. My kickstart file runs fine for fedora 31.

# Disk partitioning information
part /boot/efi --fstype="efi" --fsoptions="umask=077,shortname=winnt"
part /home --fstype="ext4" --noformat --label=HOME
part / --fstype="ext4" --label=ROOT
part swap --fstype="swap" --label=SWAP

Comment 1 Vendula Poncova 2020-03-09 13:21:17 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/2365

Comment 2 louisgtwo 2020-03-10 19:05:00 UTC
I don't see this version anywhere. koji has 32.24.2-3

Comment 3 Vendula Poncova 2020-03-11 11:10:02 UTC
The version 32.24.3-1 will be released after the Beta Freeze of Fedora 32. If you want this fix in Beta, you can propose this a bug as a blocker or a freeze exception. See: https://fedoraproject.org/wiki/Milestone_freezes

Comment 4 Fedora Update System 2020-03-17 13:47:19 UTC
FEDORA-2020-84ddf3ee4d has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-84ddf3ee4d

Comment 5 Fedora Update System 2020-03-18 02:38:26 UTC
anaconda-32.24.3-1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-84ddf3ee4d

Comment 6 Fedora Update System 2020-03-22 03:08:58 UTC
anaconda-32.24.3-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Vendula Poncova 2020-04-09 15:36:17 UTC
*** Bug 1820771 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.