Bug 18113 - Gnome Panel segfaults
Gnome Panel segfaults
Status: CLOSED DUPLICATE of bug 16891
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-02 13:14 EDT by Al Potter
Modified: 2013-04-02 00:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 18:10:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Al Potter 2000-10-02 13:14:19 EDT
Just installed RH 7.0 (downloaded 2 iso set) and after configuring X and
startx-ing, the gnome panel does not start.  Opening an xterm and
attempting to start it manually yields:

[apotter@da27 apotter]$ panel
Segmentation fault
[apotter@da27 apotter]$

To rule out the chance of a corrupt binary, I recompiled the .src.rpm for
gnome-core and installed it, with the same results.

The machine is a Dell Inspiron 5000e notebook, PIII 750 w/ 192MB of ram.
Comment 1 Mark Allen 2000-10-02 17:58:43 EDT
Just to chime in, we're testing Red Hat 7.0 on a Compal N38W2 (the OEM white box
version of the Dell Inspiron 5000e), which has the ATI Mobility M3 Rage 128
video chipset.  We have the exact same symptoms as this user, but it seems like
what's causing the segfault (according to strace output) is an incomplete read
from /proc/apm.  

In fact, if I just type 'cat /proc/apm' at the command line, I get a segfault
too. So it may be a problem with apmd or the apm code in the kernel, not
necessarily with the panel app itself.

I'm going to try compiling a new 2.2.17 kernel and see if that fixes the
problem.
Comment 2 Mark Allen 2000-10-02 19:49:40 EDT
Yep. It's something in the 2.2.x kernel APM code that seems to make panel die a
horrible death.  The 2.4.0-test8 kernel I just built runs panel just fine.  If
you're suffering from this problem, use 2.4.0 until whatever is broken in 2.2
gets fixed.
Comment 3 Al Potter 2000-10-16 18:10:36 EDT
Something strange is going on....  I installed HelixGnome and their panel
works.  apm still segfaults.


At least the panel is working......
Comment 4 Elliot Lee 2001-01-31 18:04:12 EST

*** This bug has been marked as a duplicate of 16891 ***
Comment 5 gbeer 2001-01-31 22:48:19 EST
This was marked as a dup of 16891. I tried to look at that link and recieved a
permission denied type of error. I'm curious why Bugzilla blocks access to some
bugs?

Note You need to log in before you can comment on or make changes to this bug.