Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1811427 - dnf is very slow on one of my computers - both in a virtualbox rawhide VM and on the mageia v8 host
Summary: dnf is very slow on one of my computers - both in a virtualbox rawhide VM and...
Keywords:
Status: CLOSED DUPLICATE of bug 1811426
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-08 15:05 UTC by Shlomi Fish
Modified: 2020-03-09 12:25 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-09 12:25:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Shlomi Fish 2020-03-08 15:05:33 UTC
Description of problem:

dnf is very slow on one of my computers - both in a virtualbox rawhide VM and on the mageia v8 host. It takes about  20 seconds to install a single small .rpm which accummulates to 10s of minutes for 700 updates. It is not a networking issue because i have a fast and reliable network connection of 100 megabits/second and the packages get downloaded quickly.

A manjaro linux vbox vm on the same host installs updates quickly and on a different intel nuc host on the same home network, where i have fedora 31 x64 installed DNF is very fast.

I wish to find the "magic incantation" so to speak that will make dnf fast on the problematic box.

My system hardware is:

```
My primary machine is a desktop machine with a:

    An Intel Core i3 CPU (x86-64).
    8 GB of RAM.
    Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09)
    A 2 TB hard-disk.
    A 21″ Wide LCD Screen by LG.
    Intel Corporation Cougar Point High Definition Audio Controller.
    Intel Corporation 82579V Gigabit Network Connection.



```

I can provide more info. I should note that in the past, bzr was slow on my box so it may be related: https://shlomif-tech.livejournal.com/41922.html .

Version-Release number of selected component (if applicable):

fedora rawhide

How reproducible:

Comment 1 Daniel Mach 2020-03-09 12:25:26 UTC

*** This bug has been marked as a duplicate of bug 1811426 ***


Note You need to log in before you can comment on or make changes to this bug.