Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1811709 - [NooBaa UI] onRelease causes some dialog boxes to close
Summary: [NooBaa UI] onRelease causes some dialog boxes to close
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenShift Container Storage
Classification: Red Hat
Component: Multi-Cloud Object Gateway
Version: 4.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: OCS 4.5.0
Assignee: Ohad
QA Contact: Ben Eli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-09 15:26 UTC by Ben Eli
Modified: 2020-09-15 10:16 UTC (History)
5 users (show)

Fixed In Version: ocs-olm-operator:4.5.0-419.ci
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-15 10:16:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github noobaa noobaa-core pull 5959 0 None closed Track backdrop mouse state manually 2020-08-05 15:28:31 UTC
Red Hat Product Errata RHBA-2020:3754 0 None None None 2020-09-15 10:16:32 UTC

Description Ben Eli 2020-03-09 15:26:38 UTC
Description of problem (please be detailed as possible and provide log
snippests):
When an onRelease event is detected outside of certain NooBaa web UI modals (for example - cloud resource creation dialog, new connection dialog), the modal is then closed.

Version of all relevant components (if applicable):
INFO[0000] noobaa-image: noobaa/noobaa-core:5.3.0-master20200209 
INFO[0000] operator-image: noobaa/noobaa-operator:2.1.0
OCS operator 4.3.0-ci.357

Does this issue impact your ability to continue to work with the product
(please explain in detail what is the user impact)?
No

Is there any workaround available to the best of your knowledge?
No

Rate from 1 - 5 the complexity of the scenario you performed that caused this
bug (1 - very simple, 5 - very complex)?
1

Can this issue be reproduced?
Yes

Can this issue reproduce from the UI?
Yes

Steps to Reproduce:
1. Click anywhere inside the dialog
2. With the mouse button still pressed, drag the mouse out of the dialog
3. Release the click


Actual results:
The dialog closes

Expected results:
The dialog remains open

Additional info:

Comment 2 Ohad 2020-03-25 20:34:00 UTC
Fixed in upstream PR (see links)

Comment 5 Ben Eli 2020-06-11 06:02:17 UTC
Tested using the `Add Cloud Resource` and `Add new connection` dialog boxes.

Verified.
ocs-operator.v4.5.0-448.ci
4.5.0-0.nightly-2020-06-10-201008

Comment 8 errata-xmlrpc 2020-09-15 10:16:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenShift Container Storage 4.5.0 bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3754


Note You need to log in before you can comment on or make changes to this bug.