Bug 1811739 - kube-proxy metrics are missing
Summary: kube-proxy metrics are missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Juan Luis de Sousa-Valadas
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On:
Blocks: 1810725
TreeView+ depends on / blocked
 
Reported: 2020-03-09 16:25 UTC by Juan Luis de Sousa-Valadas
Modified: 2020-07-13 17:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Changes on kube-proxy metrics implementation made some metrics disappear during the kubernetes 1.17 rebase. Consequence: Changes on kube-proxy metrics implementation made some metrics disappear during the kubernetes 1.17 rebase. Fix: Change how we publish metrics in SDN. Result: Metrics are back
Clone Of:
Environment:
Last Closed: 2020-07-13 17:19:06 UTC
Target Upstream Version:
anusaxen: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift sdn pull 114 None closed Bug 1811739: Fix kube_proxy metrics 2020-07-06 19:03:24 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:19:41 UTC

Description Juan Luis de Sousa-Valadas 2020-03-09 16:25:49 UTC
This bug was initially created as a copy of Bug #1810725

I am copying this bug because: 



Description of problem:Apparently all kubeproxy metrics are missing in 4.4 while they are present in 4.3 which were added via SDN-405 


Version-Release number of selected component (if applicable):4.4.0-0.nightly-2020-03-04-103509


How reproducible:Always


Steps to Reproduce:
1.Login to prometheus and observe kubeproxy metrics
2.
3.

Actual results: Kubeproxy metrics missing


Expected results:Kubeproxy metrics are expected


Additional info:

Comment 4 Anurag saxena 2020-03-12 14:59:49 UTC
@Aniket, Sure i am looking at this

Comment 5 Anurag saxena 2020-03-12 16:07:43 UTC
Looks good to me on 4.5.0-0.nightly-2020-03-11-161108
All kubeproxy metrics are being reported fine now.

Comment 7 errata-xmlrpc 2020-07-13 17:19:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.