Bug 1811850 - Request to backport patches for fixing backlight support on the ThinkPad P1 2nd Gen, ThinkPad X1 Extreme 2nd Gen
Summary: Request to backport patches for fixing backlight support on the ThinkPad P1 2...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lyude
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-03-09 22:57 UTC by Lyude
Modified: 2020-03-12 18:57 UTC (History)
21 users (show)

Fixed In Version: kernel-5.6.0-0.rc5.git0.2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-12 18:57:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Lyude 2020-03-09 22:57:42 UTC
1. Please describe the problem:
On certain Lenovo laptops, backlight control is non-functional due to Lenovo switching over to AMOLED backlights, which apparently require eDP AUX controlled backlight support. This is already supported by i915, but there were multiple bugs that prevented it from working properly before:

https://patchwork.freedesktop.org/series/69914/ (this is probably already in 5.6)
https://patchwork.freedesktop.org/series/72991/ (this is likely what will need to be backported)


2. What is the Version-Release number of the kernel:
kernel-5.6.0-0.rc4.git0.1.fc32

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

nope

4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Yep. Get an X1 Extreme 2nd Generation laptop with an AMOLED display, or a Lenovo ThinkPad P1 2nd Generation with AMOLED. Turn it on and watch as your attempts to change the backlight level on it fail.

5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:
Yes

6. Are you running any modules that not shipped with directly Fedora's kernel?:
No

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Going to assume we can skip this bit here since we know the patches that need to be backported and the problem.


-------
Bonus round:

1. Why is Lyude asking for this so close to the go/no-go deadline?

So: we actually got this request from Lenovo directly within the past few days. I can give you more details then that, but you will have to poke me on IRC (Lyude, @ Freenode) for the time being if you're curious.

2. When will these patches be backported for inclusion in the Fedora kernel, if the Fedora kernel decides to allow it?

I can get them onto the fedora-kernel list first thing when I get into the office tomorrow.

Comment 1 Fedora Blocker Bugs Application 2020-03-10 17:56:14 UTC
Proposed as a Freeze Exception for 32-beta by Fedora user lyude using the blocker tracking app because:

 A few variants of ThinkPads use AMOLED displays which make use of a new backlight interface over DP AUX. While this backlight interface is supported in i915, there were a number of issues found on laptops that would prevent i915 from correctly detecting DP AUX backlight support and as a result, backlight controls on these laptops don't work properly without passing i915.enable_dpcd_backlight=1 to the kernel boot parameters. Lenovo would like to see a couple of their systems work out of the box with Fedora 32, backlight control included, and actually asked me to request this for them.

Note that the patches in question can be found here and here:

https://patchwork.freedesktop.org/series/69914/
https://patchwork.freedesktop.org/series/72991/

They don't apply cleanly, so I'll be sending out some fixed up versions of the patches to the fedora-kernel list after filing this

Comment 2 Jeremy Cline 2020-03-11 00:07:11 UTC
Patches are in kernel-5.6.0-0.rc5.git0.2.fc32: https://bodhi.fedoraproject.org/updates/FEDORA-2020-55b2b79091

Comment 3 Adam Williamson 2020-03-11 16:11:17 UTC
I'm +1 FE for this, for the record; it's not that critical, but it *is* annoying if you have affected hardware, and we can't fix it for the live desktop environments with an update.

We're probably going to get the fix anyway as it's bundled with an accepted FE and an accepted blocker.

Comment 4 Fedora Update System 2020-03-11 16:45:19 UTC
FEDORA-2020-55b2b79091 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-55b2b79091

Comment 5 Fedora Update System 2020-03-12 18:57:11 UTC
kernel-5.6.0-0.rc5.git0.2.fc32, kernel-headers-5.6.0-0.rc5.git0.1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.