Bug 1811914 - Install alsa-sof-firmware package by default
Summary: Install alsa-sof-firmware package by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-sof-firmware
Version: 32
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1816923 (view as bug list)
Depends On:
Blocks: 1816645 F32BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-03-10 08:00 UTC by Jaroslav Kysela
Modified: 2020-03-25 10:38 UTC (History)
6 users (show)

Fixed In Version: alsa-sof-firmware-1.4.2-4.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-13 19:37:22 UTC
Type: Bug
bcotton: fedora_prioritized_bug-
jkysela: rhel-rawhide+


Attachments (Terms of Use)

Description Jaroslav Kysela 2020-03-10 08:00:10 UTC
The newer integrated soundcards from Intel use DSP which is used for the digital microphone input at the moment.

The sound should work right after installation without a requirement to install an additional package for the mainstream hardware.

Fix: Install alsa-sof-firmware by default (comps).

Comment 1 Fedora Blocker Bugs Application 2020-03-10 08:19:41 UTC
Proposed as a Freeze Exception for 32-beta by Fedora user perex using the blocker tracking app because:

 Install the required firmware files for the common sound hardware.

Comment 2 Jaroslav Kysela 2020-03-10 08:34:20 UTC
https://pagure.io/fedora-comps/pull-request/465

Comment 3 Peter Robinson 2020-03-10 08:35:20 UTC
>  Install the required firmware files for the common sound hardware.

Please also submit alsa-sof-firmware-1.4.2-3.fc32 as an update linked to this BZ in the update.

Comment 4 Fedora Update System 2020-03-10 09:03:23 UTC
FEDORA-2020-0a7be7437f has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0a7be7437f

Comment 5 Ben Cotton 2020-03-10 14:41:07 UTC
+1 Freeze exception

Comment 6 Fedora Update System 2020-03-10 18:06:45 UTC
alsa-firmware-1.2.1-7.fc32, alsa-sof-firmware-1.4.2-3.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-0a7be7437f

Comment 7 Miro Hrončok 2020-03-11 15:06:43 UTC
+1 Freeze exception

Comment 8 Ben Cotton 2020-03-11 17:00:44 UTC
Since this bug is already ON_QA and appears to be likely to get a freeze exception, we decided to reject it as a Prioritized Bug: https://meetbot.fedoraproject.org/fedora-meeting/2020-03-11/fedora_prioritized_bugs_and_issues.2020-03-11-15.00.log.html#l-33

Comment 9 Adam Williamson 2020-03-11 19:40:52 UTC
+1 FE for me too, so setting accepted (that's +3).

Comment 10 Ben W 2020-03-12 14:20:17 UTC
I'm having difficulty with this on F32. On a freshly installed F32 system I had no audio, so I attempted to implement some of the changes that had worked on F31:
https://bugzilla.redhat.com/show_bug.cgi?id=1772498#c224
I still couldn't get it working properly, but I was directed here as that bug is for F31.

I removed the config changes I'd made to the pulse default.pa file, and now I do see sof related lines in dmesg:

[   17.746357] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[   17.747565] sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[   17.748641] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
[   17.748790] sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   17.754640] sof-audio-pci 0000:00:1f.3: use msi interrupt mode
[   17.857901] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[   17.857903] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[   17.860451] sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cml.ri failed with error -2
[   17.860453] sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-cml.ri failed err: -2
[   17.860454] sof-audio-pci 0000:00:1f.3: error: failed to load DSP firmware -2
[   17.861501] sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -2

gnome just shows "Dummy Output" and no mic.

> Thinkpad X11 Carbon Gen 7
> Kernel 5.6.0-0.rc4.git0.1.fc32.x86_64
> pulseaudio-13.99.1-1.fc32.x86_64
> alsa-firmware-1.2.1-7.fc32.noarch
> alsa-sof-firmware-1.4.2-3.fc32.noarch
> alsa-ucm-1.2.2-1.fc32.noarch

Comment 11 Adam Williamson 2020-03-12 15:11:48 UTC
Can you please file a new bug? This bug is just for the package dependency changes, it will be closed when the update is pushed stable. It's not for problems with sound even if both packages are installed. Thanks.

Comment 12 Ben W 2020-03-12 15:23:53 UTC
Apologies; filed here: https://bugzilla.redhat.com/show_bug.cgi?id=1812964

Comment 13 Fedora Update System 2020-03-12 18:33:41 UTC
FEDORA-2020-0a7be7437f has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0a7be7437f

Comment 14 Fedora Update System 2020-03-13 18:33:13 UTC
alsa-firmware-1.2.1-7.fc32, alsa-sof-firmware-1.4.2-4.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-0a7be7437f

Comment 15 Fedora Update System 2020-03-13 19:37:22 UTC
alsa-firmware-1.2.1-7.fc32, alsa-sof-firmware-1.4.2-4.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Jaroslav Kysela 2020-03-25 10:38:16 UTC
*** Bug 1816923 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.