Bug 1811946 - Changing PXELoader for a Host in Build mode does not redeploy the bootloader configs to TFTP
Summary: Changing PXELoader for a Host in Build mode does not redeploy the bootloader ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Ondrej Gajdusek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-10 09:51 UTC by Roman Plevka
Modified: 2021-07-09 17:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-09 17:02:24 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Roman Plevka 2020-03-10 09:51:48 UTC
Description of problem:
When I try to change a pxeloader of a host in a build mode, the foreman does not run the TFTP config redeploy, it only overwrites the DHCP reservation.

Version-Release number of selected component (if applicable):
6.7.0 snap 15

Steps to Reproduce:
1. create a new host with GRUB2 BIOS pxeloader
2. watch the grub config being deployed to tftp
3. the grub.cfg for the host should contain "initrd" and "linux" commands inside the menu entries
4. edit the host (while still in boot mode)
5. update the pxe loader to "GRUB2 UEFI" and save
6. notice that the orchestration doesn't run any TFTP task (probably dhcp one only)
7. see that the PXELoader attribute of the host is now updated (in foreman)
8. check the grub config file on tftp again and notice that it is still the old config (linux, initrd commands instead of linuxefi and initrdefi)

Actual results:
foreman doesn't reflect the pxeloader change and skips TFTP file redeployment

Expected results:
foreman should regenerate the bootloader config based on the relevant changes to the host record

Comment 5 Roman Plevka 2020-03-20 16:43:15 UTC

*** This bug has been marked as a duplicate of bug 1778827 ***

Comment 6 Lukas Zapletal 2020-04-22 06:51:57 UTC
No this is still a problem, the other BZ resolved conflicts.

Comment 7 Mike McCune 2021-07-09 17:02:24 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this feel free to contact your Red Hat Account Team. Thank you.


Note You need to log in before you can comment on or make changes to this bug.