Bug 1812014 - clevis missing dependency on cracklib-dicts
Summary: clevis missing dependency on cracklib-dicts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: clevis
Version: 8.2
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: 8.2
Assignee: Sergio Correia
QA Contact: Martin Zelený
URL:
Whiteboard:
Depends On:
Blocks: 1812000
TreeView+ depends on / blocked
 
Reported: 2020-03-10 11:43 UTC by SATHEESARAN
Modified: 2020-11-04 03:11 UTC (History)
18 users (show)

Fixed In Version: clevis-13-1.el8
Doc Type: No Doc Update
Doc Text:
Clone Of: 1812000
Environment:
Last Closed: 2020-11-04 03:09:18 UTC
Type: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4701 0 None None None 2020-11-04 03:09:30 UTC

Description SATHEESARAN 2020-03-10 11:43:18 UTC
Description of problem:
-----------------------
For network bound disk encryption to work, the package - 'cracklib-dicts' needs to be included in RHVH 4.4

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHVH-UNSIGNED-ISO-4.4-RHEL-8-20200308.0-RHVH-x86_64-dvd1.iso

How reproducible:
-----------------
Always

Steps to Reproduce:
--------------------
1. Setup a tang server
2. Try to do a clevis-luks-bind to tang server

Actual results:
---------------
[root@ ~]# clevis luks bind -f -k /etc/key -d /dev/sda2 tang '{"url":"http://10.70.35.6","adv":"/etc/adv.jws"}'
/usr/share/cracklib/pw_dict.pwd.gz: No such file or directory
/usr/share/cracklib/pw_dict.pwd.gz: No such file or directory
/usr/share/cracklib/pw_dict.pwd.gz: No such file or directory
Error: Password generation failed - required entropy too low for settings
Password quality check failed:
 No password supplied
Failed to import token from file.
Error while saving Clevis metadata as a LUKS token!
No key available with this passphrase.

Expected results:
------------------
Successful bind to tang server

Comment 16 errata-xmlrpc 2020-11-04 03:09:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (clevis bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4701


Note You need to log in before you can comment on or make changes to this bug.