Bug 1812071 - connect to etcd using ips
Summary: connect to etcd using ips
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Luis Sanchez
QA Contact: Ke Wang
URL:
Whiteboard:
: 1811530 1812409 (view as bug list)
Depends On: 1810133
Blocks: 1807194 1810490
TreeView+ depends on / blocked
 
Reported: 2020-03-10 13:27 UTC by Luis Sanchez
Modified: 2020-05-13 22:01 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1810133
Environment:
Last Closed: 2020-05-13 22:01:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-kube-apiserver-operator pull 791 0 None closed [release-4.4] Bug 1812071: connect to etcd using IPs 2020-11-19 10:28:28 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:01:11 UTC

Comment 3 Stephen Cuppett 2020-03-11 13:29:46 UTC
*** Bug 1811530 has been marked as a duplicate of this bug. ***

Comment 4 Martin André 2020-03-11 13:50:51 UTC
*** Bug 1812409 has been marked as a duplicate of this bug. ***

Comment 5 Ke Wang 2020-03-17 03:58:45 UTC
Verified the OCP build 4.4.0-0.nightly-2020-03-15-215151, steps see below,

$ oc get kubeapiserver/cluster -o json | jq .spec.observedConfig.storageConfig
{
  "urls": [
    "https://192.168.0.22:2379",
    "https://192.168.0.24:2379",
    "https://192.168.0.30:2379",
    "https://localhost:2379"
  ]
}

logged into the master node and searching related keywords,

$ oc get nodes
NAME                           STATUS   ROLES    AGE   VERSION
keosp1641-wq2sw-master-0       Ready    master   20h   v1.17.1
keosp1641-wq2sw-master-1       Ready    master   20h   v1.17.1
keosp1641-wq2sw-master-2       Ready    master   20h   v1.17.1
keosp1641-wq2sw-worker-lzdx2   Ready    worker   20h   v1.17.1
keosp1641-wq2sw-worker-s4j54   Ready    worker   20h   v1.17.1
keosp1641-wq2sw-worker-z29ml   Ready    worker   20h   v1.17.1

$ oc debug node/keosp1641-wq2sw-master-0
Starting pod/keosp1641-wq2sw-master-0-debug ...
To use host binaries, run `chroot /host`
Pod IP: 192.168.0.30
If you don't see a command prompt, try pressing enter.

sh-4.2# chroot /host
sh-4.4# cd /var/log/pods
sh-4.4# grep -nr 'https://etcd' openshift*

sh-4.4# grep -nr 'host-etcd' openshift*
openshift-sdn_sdn-bjc8m_5a8057be-25de-476a-9d95-2af82aba2cf1/sdn/0.log:74:2020-03-16T07:23:11.384356349+00:00 stderr F I0316 07:23:11.384325    3480 roundrobin.go:235] LoadBalancerRR: Setting endpoints for openshift-etcd/host-etcd:etcd to [192.0.2.2:2379 192.0.2.200:2379 192.0.2.3:2379 192.0.2.4:2379]
openshift-sdn_sdn-bjc8m_5a8057be-25de-476a-9d95-2af82aba2cf1/sdn/0.log:82:2020-03-16T07:23:11.384673997+00:00 stderr F I0316 07:23:11.384664    3480 roundrobin.go:235] LoadBalancerRR: Setting endpoints for openshift-etcd/host-etcd-2:etcd to [192.168.0.22:2379 192.168.0.24:2379 192.168.0.30:2379]

  
The above found ‘host-etcd’ in log file, it is reasonable at present stage, see https://bugzilla.redhat.com/show_bug.cgi?id=1810133#c8,  move the bug verify.

Comment 7 errata-xmlrpc 2020-05-13 22:01:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.