Bug 1812072 - while attempting for NBDE, blacklist the devices based on requirements
Summary: while attempting for NBDE, blacklist the devices based on requirements
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-ansible
Version: rhgs-3.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.5.z Batch Update 2
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1812048
TreeView+ depends on / blocked
 
Reported: 2020-03-10 13:32 UTC by SATHEESARAN
Modified: 2020-06-16 05:57 UTC (History)
5 users (show)

Fixed In Version: gluster-ansible-infra-1.0.4-6.el8rhgs
Doc Type: No Doc Update
Doc Text:
Clone Of: 1812048
Environment:
rhhiv, rhel8
Last Closed: 2020-06-16 05:57:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github gluster gluster-ansible-infra pull 82 0 None closed NBDE and blacklist issue fixes 2020-06-03 05:30:26 UTC
Github gluster gluster-ansible pull 97 0 None closed Validate if root device is encrypted prior to actual configuration 2020-06-03 05:30:25 UTC
Red Hat Product Errata RHEA-2020:2575 0 None None None 2020-06-16 05:57:52 UTC

Description SATHEESARAN 2020-03-10 13:32:37 UTC
Description of problem:
-----------------------
As I look at the code, it tries to blacklist the disks before turning on NBDE.
We should really look for inputs from user, whether they have multipath in the configuration. Only in the absence of multipath configuration, all the required devices should be blacklisted

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
gluster-ansible-infra-1.0.4-5.el8rhgs.noarch.rpm

How reproducible:
-----------------
Always

Actual results:
----------------
All the devices are blacklisted

Expected results:
-----------------
Devices should be blacklisted based on the requriements
Default behavior should be blacklisting the required devices.

--- Additional comment from SATHEESARAN on 2020-03-10 12:37:53 UTC ---

Also the procedure to blacklist is by adding the blacklist block to the file created under /etc/multipath/conf.d/<file.conf>

Comment 2 SATHEESARAN 2020-03-21 10:59:23 UTC
Tested with gluster-ansible-infra-1.0.4-6

1. Devices are blacklisted based on the requirement

Comment 6 errata-xmlrpc 2020-06-16 05:57:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:2575


Note You need to log in before you can comment on or make changes to this bug.