Bug 1812181 - Modifying network settings through `gnome-control-center` leads to a crash and generates a core dump
Summary: Modifying network settings through `gnome-control-center` leads to a crash an...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 32
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-10 17:36 UTC by Stefano Figura
Modified: 2020-03-24 20:40 UTC (History)
6 users (show)

Fixed In Version: gnome-control-center-3.36.0-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 20:40:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Stefano Figura 2020-03-10 17:36:42 UTC
Description of problem:

Modifying network settings through `gnome-control-center` leads to a crash and generates a core dump

Version-Release number of selected component (if applicable):

gnome-control-center-3.35.92-1.fc32.x86_64

How reproducible:

This can be reproduced 100% of the times on 2 different machines. 

Steps to Reproduce:

The issue con be reproduced by changing practically any settings within the "Wired" or "Wireless" settings view.

1. Click on the Network settings on the top right hand corner
2. Click on "WiFi Settings" (or "wired Settings"
3. Click on the settings cog besides the AP you want to modify
4. Click on "IPv4" tab 
5. Disable Automatic DNS
6. Insert a DNS (e.g.: 9.9.9.9)
7. Click "Apply".

Actual results:

`gnome-control-center` will crash and the settings won't be applied


Expected results:

Settings are applied without any crash 


Additional info:

This can be reproduced on 2 separate machines both on the same compose of Fedora 32

Comment 1 Garrett LeSage 2020-03-11 08:56:02 UTC
I also see this on Silverblue 32.20200310.n.0 (Fedora pre-32) with gnome-control-center-3.35.92-1.fc32.x86_64

BTW: Upstream issue also filed (by Stefano) @ https://gitlab.gnome.org/GNOME/gnome-control-center/issues/906

Comment 2 Kalev Lember 2020-03-19 11:46:29 UTC
I think this is the missing libnm gschema issue that mcatanzaro has been working on.

Michael, did you get any traction with moving the gschema out of nm-connection-editor or should we add back the requires in gnome-control-center?

Comment 3 Michael Catanzaro 2020-03-19 15:23:32 UTC
Thomas was working on this. Looks like he's fixed it in rawhide, but not in F32.

Thomas, how about I just have gnome-control-center Requires: network-manager-applet again, but only in F32? That seems simpler at this point than upgrading libnma and network-manager-applet in F32? I'm glad we've got it fixed properly in rawhide, and restoring this little workaround for F32 seems unproblematic to me.

Comment 4 Thomas Haller 2020-03-19 15:49:34 UTC
yes, that's what I said here: https://gitlab.gnome.org/GNOME/gnome-control-center/issues/881#note_732240

Quite possibly, Fedora 32 will also eventually get an update to libnma-1.8.28+ and network-manager-applet-1.16.0+. However, I'd like to first get some feedback that shows that these versions aren't terribly broken (because they bring large changes).

Comment 5 Fedora Update System 2020-03-19 16:54:50 UTC
FEDORA-2020-d7cff22b0c has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d7cff22b0c

Comment 6 Fedora Update System 2020-03-20 01:59:12 UTC
gnome-control-center-3.36.0-3.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d7cff22b0c

Comment 7 Fedora Update System 2020-03-24 20:40:01 UTC
FEDORA-2020-d7cff22b0c has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.