Bug 1812250 - virt-v2v fails to import vmdk files ending with '-flat.vmdk' .
Summary: virt-v2v fails to import vmdk files ending with '-flat.vmdk' .
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: virt-v2v
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Richard W.M. Jones
QA Contact: mxie@redhat.com
URL:
Whiteboard: V2V
Depends On:
Blocks: 1897025
TreeView+ depends on / blocked
 
Reported: 2020-03-10 20:18 UTC by Daniel Kallner
Modified: 2021-04-27 16:13 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-27 16:13:41 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
import log (4.03 KB, text/plain)
2020-03-10 20:18 UTC, Daniel Kallner
no flags Details
Index of vmdk folder (4.06 KB, text/html)
2020-03-10 20:19 UTC, Daniel Kallner
no flags Details
guest-cannot-power-on-after-delete-flat-vmdk.png (72.85 KB, image/png)
2021-04-19 14:31 UTC, mxie@redhat.com
no flags Details

Description Daniel Kallner 2020-03-10 20:18:36 UTC
Created attachment 1669058 [details]
import log

Description of problem:
virt-v2v should migrate vmdk files even if there are no files ending with '-flat.vmdk' .


Version-Release number of selected component (if applicable):
RHHI 1.6 using RHV 4.3
Product Name:   Red Hat Virtualization Host
Product ID:     328
Version:        4.3
virt-v2v-1.40.2-5.el7_7.3.x86_64



How reproducible:
100%


Steps to Reproduce:
1. Use specific VMware images built with files as described in the attachment.
2. Try to migrate using RHV UI (using virt-v2v) from VMware to RHV. Using VMware apis.
3. Migration fails.

Actual results:
Import fails


Expected results:
Import should work.

Additional info:
A. This is coming from a deployment on site with a strategic customer to Red Hat. There's a support case for this: https://access.redhat.com/support/cases/#/case/02592484
B. Richard already started to assist us with this issue until we found this bug.

Comment 1 Daniel Kallner 2020-03-10 20:19:54 UTC
Created attachment 1669059 [details]
Index of vmdk folder

Comment 2 Richard W.M. Jones 2020-03-10 20:24:41 UTC
Please use OVA export from VMware / import to RHV as an alternative
workaround for now.

Comment 3 Richard W.M. Jones 2020-03-11 09:54:22 UTC
Please could you ask the customer for:

Dev-Allianz-Confluence4.vmdk                                                
Dev-Allianz-Confluence4.vmsd                                                
Dev-Allianz-Confluence4.vmx                                                 

(They can be sent privately to me by email if the customer would
prefer not to attach them to the bug)

I would also like to know the version of VMware they are using.

Comment 4 Daniel Kallner 2020-04-07 10:16:36 UTC
Customer is not able to send the files due to security limitations.

Comment 8 mxie@redhat.com 2021-04-19 14:29:06 UTC
I don't understand why the customer's VMware guest doesn't have "-flat.vmdk" file.  "-flat.vmdk" file will be created automatically if new guest is created on VMware. Besides, if delete file ""-flat.vmdk" on VMware host, then the guest can't be power on on vSphere client with error ".....vmdk was not found", details pls refer to screenshot 'guest-cannot-power-on-after-delete-flat-vmdk.png'

Log into ESXi host to check the files of guests in datastore:
[root@bootxxx:/vmfs/volumes/5aefd41e-1d448cf8-0b1f-001018d0c8e0/esx6.7-new-guest] ls
esx6.7-new-guest-4bacff40.hlog  esx6.7-new-guest.vmdk           esx6.7-new-guest.vmx
esx6.7-new-guest-flat.vmdk      esx6.7-new-guest.vmsd

Comment 9 mxie@redhat.com 2021-04-19 14:31:22 UTC
Created attachment 1773298 [details]
guest-cannot-power-on-after-delete-flat-vmdk.png

Comment 13 Richard W.M. Jones 2021-04-27 16:13:41 UTC
Per comment 4, we cannot solve this.


Note You need to log in before you can comment on or make changes to this bug.