Bug 1812293 - F32 background not used on desktop by default (but is used on login screen, lock screen)
Summary: F32 background not used on desktop by default (but is used on login screen, l...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: 32
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa AcceptedBlocker https://fedora...
Depends On:
Blocks: F32FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-03-10 23:43 UTC by Adam Williamson
Modified: 2020-03-23 20:23 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-23 20:23:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2020-03-10 23:43:05 UTC
Even with everything I can find to fix fixed, the F32 background is not being used for newly-created users in KDE.

https://bodhi.fedoraproject.org/updates/FEDORA-2020-41f8211c33 is my latest effort to fix stuff: it fixes a dep in kde-settings and some bad symlinks in f32-backgrounds-kde . With that I cannot see anything wrong anywhere. But if you install a KDE live then update those two packages in the installed system before you ever boot it, when you boot and log in, you still get the 'Next' background (the one that's orange in bottom left and blue-y in top right and they meet in the middle). Also if you create a brand new user, it gets the 'Next' background.

The F32 theme does exist and works - if you right-click and hit Configure Desktop...you see 'Fedora Thirty-Two' as an option (it's even got a blue surround as if it were already selected, which is odd) and if you click on it and hit 'Apply', you get the F32 background right away. But it's not used by default and I cannot figure out why not.

[root@localhost-live share]# rpm -qa | grep backgr
desktop-backgrounds-compat-32.0.0-3.fc32.noarch
f32-backgrounds-kde-32.0.0-3.fc32.noarch
f32-backgrounds-base-32.0.0-3.fc32.noarch
[root@localhost-live share]# rpm -q kde-settings
kde-settings-32.0-2.fc32.noarch

Proposing as a Final blocker, per criterion "The proposed final Fedora artwork must be included and used as the background on release-blocking desktops" - https://fedoraproject.org/wiki/Fedora_32_Final_Release_Criteria#Artwork . Also proposing as a Beta FE; obviously it'd be good to get the right background on KDE in the Beta.

Comment 1 Rex Dieter 2020-03-11 00:33:37 UTC
I'll take a closer look tomorrow

Comment 2 Adam Williamson 2020-03-12 15:08:14 UTC
For the record, Rex figured out the cause of this, but fixing it isn't entirely straightforward as it involves changing a Plasma package which had already been bumped to 5.18.3. Moving it backwards to 5.18.2 is difficult, but otherwise we'd have to pull the whole 5.18.3 into Beta just to fix the background, which would be silly.

So, we just left it as-is for the first Beta candidate. As the background is not the same as any previous Fedora release, it doesn't violate the Beta criteria.

Comment 3 Adam Williamson 2020-03-14 19:14:34 UTC
Dropping FE nomination as we already signed off Beta.

Comment 4 Geoffrey Marr 2020-03-16 19:11:09 UTC
Discussed during the 2020-03-16 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"The proposed final Fedora artwork must be included and used as the background on release-blocking desktops."

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-16/f32-blocker-review.2020-03-16-16.03.txt

Comment 5 Adam Williamson 2020-03-18 19:56:47 UTC
Rex, the Plasma 5.18.3 update is pushed stable now. Can you go ahead and make the necessary changes to fix this now? Thanks!

Comment 6 Rex Dieter 2020-03-19 22:35:21 UTC
https://bodhi.fedoraproject.org/updates/FEDORA-2020-d13ac577eb

should do it

Comment 7 Rex Dieter 2020-03-19 22:38:32 UTC
Cliff's notes change:
kde-settings-plasma adds symlink /usr/share/wallpapers/Fedora pointing to /usr/share/wallpapers/F32
and
plasma-lookandfeel-fedora includes
/usr/share/plasma/look-and-feel/org.fedoraproject.fedora.desktop/contents/defaults
with content snippet:
[Wallpaper]
Image=Fedora

Comment 8 Fedora Update System 2020-03-20 01:59:25 UTC
kde-settings-32.0-3.fc32, plasma-workspace-5.18.3-2.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d13ac577eb

Comment 9 František Zatloukal 2020-03-20 09:55:05 UTC
kde-settings-32.0-3.fc32, plasma-workspace-5.18.3-2.fc32 fixes the issue.

Comment 10 Fedora Update System 2020-03-21 02:14:21 UTC
kde-settings-32.0-3.fc32, plasma-workspace-5.18.3-2.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Adam Williamson 2020-03-21 17:32:07 UTC
Hate to be the bearer of bad news, but today's 32 nightly KDE live image has a completely black screen as the background:

https://openqa.fedoraproject.org/tests/552462

Comment 12 Adam Williamson 2020-03-21 17:32:44 UTC
Rawhide has the right background, so we may be missing something in 32 that's in Rawhide...

Comment 13 Adam Williamson 2020-03-21 17:33:25 UTC
Ah, my previous update https://bodhi.fedoraproject.org/updates/FEDORA-2020-41f8211c33 is still stuck in updates-testing as it does not have sufficient karma. I will drop the older kde-settings build from it, then if folks could please karma it, I can push it stable and we should be good.

Comment 14 Fedora Update System 2020-03-21 17:36:20 UTC
FEDORA-2020-41f8211c33 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-41f8211c33

Comment 15 Fedora Update System 2020-03-22 01:41:17 UTC
f32-backgrounds-32.0.0-3.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-41f8211c33

Comment 16 František Zatloukal 2020-03-23 09:16:34 UTC
So, installing https://bodhi.fedoraproject.org/updates/FEDORA-2020-41f8211c33 into the F32 KDE System (newly installed, from netinst, with the other packages fixing KDE wallpaper stuff) fixes the black wallpaper issue.

However, I didn't make a new installation image with this, hope just test with updating is enough.

Comment 17 Fedora Update System 2020-03-23 20:23:48 UTC
FEDORA-2020-41f8211c33 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.