Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1812320 - cluster-etcd-operator: discover-etcd-initial-cluster should use actual data-dir
Summary: cluster-etcd-operator: discover-etcd-initial-cluster should use actual data-dir
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd Operator
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 1812319
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 01:43 UTC by Sam Batschelet
Modified: 2020-05-04 11:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1812319
Environment:
Last Closed: 2020-05-04 11:45:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 250 0 None closed [release-4.4] Bug 1812320: The data-dir should be /var/lib/etcd instead of /var/lib/etcd/member … 2020-10-28 20:26:55 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:46:06 UTC

Description Sam Batschelet 2020-03-11 01:43:33 UTC
+++ This bug was initially created as a clone of Bug #1812319 +++

Description of problem: discover-etcd-initial-cluster in the etcd-pod.yaml uses /var/lib/etcd/member instead of /var/lib/etcd for data-dir flag.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: data-dir flag has wrong value.


Expected results: we use proper data-dir


Additional info:

Comment 5 errata-xmlrpc 2020-05-04 11:45:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.