Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1812335 - Bond: cannot set back 'arp_ip_target' and 'arp_interval' options to default value
Summary: Bond: cannot set back 'arp_ip_target' and 'arp_interval' options to default v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: nmstate
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.3
Assignee: Gris Ge
QA Contact: Mingyu Shi
URL:
Whiteboard:
: 1828302 (view as bug list)
Depends On:
Blocks: 1817478
TreeView+ depends on / blocked
 
Reported: 2020-03-11 03:20 UTC by Mingyu Shi
Modified: 2020-11-04 03:09 UTC (History)
6 users (show)

Fixed In Version: nmstate-0.3.2-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1817478 (view as bug list)
Environment:
Last Closed: 2020-11-04 03:08:25 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
reproducer.log (9.69 KB, text/plain)
2020-03-11 03:20 UTC, Mingyu Shi
no flags Details
verified.log (10.88 KB, text/plain)
2020-06-19 02:01 UTC, Mingyu Shi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github nmstate nmstate issues 946 0 None closed tracking issue for bond options 2021-01-25 11:21:16 UTC
Github nmstate nmstate pull 993 0 None closed state: allow missing arp_ip_target when ARP monitoring disabled 2021-01-25 11:21:16 UTC
Red Hat Product Errata RHBA-2020:4696 0 None None None 2020-11-04 03:08:42 UTC

Description Mingyu Shi 2020-03-11 03:20:34 UTC
Created attachment 1669143 [details]
reproducer.log

Description of problem:
Once you set 'arp_ip_target'(arp_interval is required meanwhile), you cannot empty it anymore. It means we can't set back 'arp_ip_target' and 'arp_interval' options to default value

Version-Release number of selected component (if applicable):
nmstate-0.2.6-3.8.el8.noarch
NetworkManager-1.22.8-4.el8.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Set a bond with 'arp_ip_target' and 'arp_interval'
2. Try to remove these two options
3.
See the attachment for the details.

Actual results:
Fail

Expected results:
No failure

Additional info:
Now you have to change 'arp_interval' and 'arp_ip_target' at the same time:
2020-03-11 11:01:39,011 root         ERROR    NM main-loop aborted: Connection adding failed: error=nm-connection-error-quark: bond.options: 'arp_interval' option requires 'arp_ip_target' option to be set (7)
2020-03-11 10:59:47,438 root         ERROR    NM main-loop aborted: Connection update failed: error=nm-connection-error-quark: bond.options: 'arp_ip_target' option requires 'arp_interval' option to be set (7), dev=temp3/<enum NM_DEVICE_STATE_ACTIVATED of type NM.DeviceState>

Comment 3 Gris Ge 2020-04-28 07:04:26 UTC
*** Bug 1828302 has been marked as a duplicate of this bug. ***

Comment 7 Mingyu Shi 2020-06-19 02:01:08 UTC
Created attachment 1698029 [details]
verified.log

verified:
nmstate-0.3.2-1.el8.noarch
NetworkManager-1.26.0-0.1.el8.x86_64
DISTRO=RHEL-8.3.0-20200616.0
Linux hp-dl388g8-08.rhts.eng.pek2.redhat.com 4.18.0-214.el8.x86_64 #1 SMP Fri Jun 12 08:55:08 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

See the attachment for details.

Comment 10 errata-xmlrpc 2020-11-04 03:08:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (nmstate bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4696


Note You need to log in before you can comment on or make changes to this bug.