Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1812360 - Rhel 7.8 ledctl command reports an error
Summary: Rhel 7.8 ledctl command reports an error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ledmon
Version: 7.8
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: Storage QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 07:07 UTC by 张茂岭
Modified: 2020-03-19 06:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-19 06:09:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
sosreport (6.21 MB, application/x-xz)
2020-03-11 07:07 UTC, 张茂岭
no flags Details

Description 张茂岭 2020-03-11 07:07:34 UTC
Created attachment 1669162 [details]
sosreport

Description of problem:
"Ledctl locate=/dev/sdc" command execution error, cannot be used.The ledmon package is ledmon-0.92-1.el7.x86_64.rpm.When a lower version of Ledmon package ledmon-0.80-2.el7.x86_64.rpm is installed, the ledctl command can be used normally.
Version-Release number of selected component (if applicable):
ledmon-0.92-1.el7.x86_64.rpm

How reproducible:
On the rhel7.8 operating system, an error occurs when you execute the ledctl locate=/dev/sdc command.

Steps to Reproduce:
1.Install the rhel7.8 operating system ;
2.Execute the “edctl locate=/dev/sdc”command.
3.

Actual results:
The execution command is prompted as follows:
[root@localhost ~]# ledctl locate /dev/sdc
/dev/shm/ledmon.conf: does not exist, using global config file
/etc/ledmon.conf: does not exist, using built-in default

Expected results:
There is no error message for executing the command as follows:
[root@localhost ~]# ledctl locate=/dev/sdc
[root@localhost ~]# 

Additional info:

Comment 2 xujin 2020-03-11 09:31:21 UTC
Hi Jan, 

Please have a look at this issue, and kindly share if it is possible to fix this issue on RHEL 7.8. 

Thanks. 


Best Regards
Edward

Comment 3 xujin 2020-03-16 07:55:14 UTC
Hi Jan, 

Hope you are doing good. 

Do you have any update on it? 

Thank you. 


Best Regards
Edward

Comment 4 Jan Synacek 2020-03-16 08:08:34 UTC
(In reply to 张茂岭 from comment #0)
> Actual results:
> The execution command is prompted as follows:
> [root@localhost ~]# ledctl locate /dev/sdc
> /dev/shm/ledmon.conf: does not exist, using global config file
> /etc/ledmon.conf: does not exist, using built-in default

I don't see any errors. The program simply states that it's using a default configuration. Since you didn't provide the exit code, I assume the command ran without any issues.

Comment 5 张茂岭 2020-03-19 02:05:57 UTC
Ok, I see.I have tested that the exit code is 0,so the prompt message is normal.You can ignore this problem.thank you!


Note You need to log in before you can comment on or make changes to this bug.