Bug 1812449 - The cursor position isn't correct during pre-editing
Summary: The cursor position isn't correct during pre-editing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F32FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-03-11 11:39 UTC by Akira TAGOH
Modified: 2020-03-24 17:50 UTC (History)
13 users (show)

Fixed In Version: mutter-3.36.0-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 17:50:50 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gtk issues 2517 0 None None None 2020-03-16 05:46:15 UTC

Description Akira TAGOH 2020-03-11 11:39:43 UTC
Description of problem:
The cursor position doesn't point to the correct place during pre-editing.

Version-Release number of selected component (if applicable):
gtk3-3.24.14-1.fc32.x86_64

How reproducible:
always

Steps to Reproduce:
1.make sure if ibus-kkc is installed and enable "Japanese (Kana Kanji)" in the input source.
2.open TextView at gtk3-demo for example
3.type Super+space watashinonamaehanakanodesu

Actual results:
わたしの|なまえはなかのです

Expected results:
わたしのなまえはなかのです|

Additional info:
This seems to be a regression since it works fine on f31. also running gtk apps with GTK_IM_MODULE=ibus also works. dunno what's wrong. so please reassign if it isn't a gtk issue.

Comment 1 Jens Petersen 2020-03-13 03:43:13 UTC
It may be good to file an upstream bug too if this is still reproducible in the Beta composes?

Comment 2 Jens Petersen 2020-03-17 04:30:46 UTC
I feel this is a potential F32 Blocker bug actually, since it affects normal CJK input badly.

Comment 3 Akira TAGOH 2020-03-17 07:49:51 UTC
https://gitlab.gnome.org/GNOME/gtk/-/commit/5ad1316b1ee11686bda63b224eacda33a2ef3e45

That upstream change seems affecting this issue. preedit works back to the normal after reverting it. reassigning this back to gtk3.

Comment 4 Akira TAGOH 2020-03-18 04:09:19 UTC
I've confirmed that the following change in mutter fixes this issue: https://gitlab.gnome.org/GNOME/mutter/-/commit/db9b60cc6357539d0deefd9ded236b1dd302d4a2

Comment 5 Geoffrey Marr 2020-03-23 19:43:19 UTC
Discussed during the 2020-03-23 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedFreezeException" was made as this is very inconvenient for the default Japanese input method and various other similar ones, and cannot be fixed for live environments with an update.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-03-23/f32-blocker-review.2020-03-23-16.00.txt

Comment 6 Fedora Update System 2020-03-23 20:23:36 UTC
FEDORA-2020-78f41bf351 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-78f41bf351

Comment 7 Fedora Update System 2020-03-24 01:52:42 UTC
FEDORA-2020-78f41bf351 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-78f41bf351`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-78f41bf351

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-03-24 17:50:50 UTC
FEDORA-2020-78f41bf351 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.