Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1812573 - New package request: python-validations-libs
Summary: New package request: python-validations-libs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-validations-libs
Version: 16.0 (Train)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: z2
: 16.1 (Train on RHEL 8.2)
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
Depends On: 1812385 1821313
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 15:35 UTC by Cédric Jeanneret
Modified: 2020-08-26 14:00 UTC (History)
6 users (show)

Fixed In Version: python-validations-libs-1.0.1-0.20200429083422.3cc5263.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-26 14:00:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Cédric Jeanneret 2020-03-11 15:35:58 UTC
Hello,

We're requesting a new package for RHEL-8, linked to OSP-16.1 and newer:
python-validations-libs

The usage is:
Set of python libraries and helpers for the Validation Framework

Upstream repository:
https://opendev.org/openstack/validations-libs

RDO change request (not yet merged, soon to be):
https://review.rdoproject.org/r/#/c/25818/

Related Package review:
https://bugzilla.redhat.com/show_bug.cgi?id=1812385

Notes:
- There isn't any encryption lib in there

Comment 5 Scott Lewis 2020-04-19 19:06:53 UTC
Removing Target Milestone; please replan

Comment 10 Alex McLeod 2020-05-11 14:22:12 UTC
Hey Cedric, is there any doc impact for this new package? Is it part of the existing repos that we instruct users to enable[1]?

Thanks!

[1] Step 13: https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/16.0/html-single/director_installation_and_usage/index#preparing-the-undercloud

Comment 11 Cédric Jeanneret 2020-05-15 06:12:11 UTC
Hello Alex,

No real doc update is needed - this is purely "cosmetic and dev cleaning". The goal of those two packages it to make the whole validation framework more portable, while providing nice binding other products/projects can re-use. No usage changes so far, and it's included in the default OSP repositories.

Cheers,

C.

Comment 12 Cédric Jeanneret 2020-07-07 13:32:58 UTC
Moving to z2 - this package is not in use for downstream right now. Discussions are still running.
Also removing the "Blocks", because it doesn't block the Validation Framework itself.


Note You need to log in before you can comment on or make changes to this bug.