Bug 1812591 - Why are the ceph repositories/containers Opt-Out instead of Opt-In?
Summary: Why are the ceph repositories/containers Opt-Out instead of Opt-In?
Keywords:
Status: CLOSED DUPLICATE of bug 1726606
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 16.0 (Train)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 16:05 UTC by David Vallee Delisle
Modified: 2020-03-11 16:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-11 16:29:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4895201 0 None None None 2020-03-11 16:05:20 UTC

Description David Vallee Delisle 2020-03-11 16:05:20 UTC
Description of problem:
When deploying OSP16 without anything Ceph related, we need to exclude the ceph repositories from the container-prepare-parameters and undefine the TripleO::Services as described here: https://access.redhat.com/solutions/4895201

We would like to confirm if there's any downside with doing this, and our customer was also wondering why it's an Opt-Out process instead of an Opt-In process.

There's some overhead work to either add these repos to satellite, or to disable the ceph services  like this.

Comment 1 Alex Schultz 2020-03-11 16:29:44 UTC
Because prior to containers we always shipped ceph in the overcloud-full image. This is a continuation of that.

*** This bug has been marked as a duplicate of bug 1726606 ***


Note You need to log in before you can comment on or make changes to this bug.