Bug 1812621 - Unable to upgrade from 4.2.z to 4.3.z
Summary: Unable to upgrade from 4.2.z to 4.3.z
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.3.z
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: Wei Sun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 17:45 UTC by Dan Yocum
Modified: 2020-04-26 10:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-26 10:58:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
stable channel upgrade screenshot error (32.63 KB, image/png)
2020-03-11 17:45 UTC, Dan Yocum
no flags Details
fast channel upgrade screenshot (47.83 KB, image/png)
2020-03-11 17:46 UTC, Dan Yocum
no flags Details

Description Dan Yocum 2020-03-11 17:45:42 UTC
Created attachment 1669407 [details]
stable channel upgrade screenshot error

Description of problem:

I have a 4.2.20 cluster subscribed to the stable channel.  I am unable to upgrade to any 4.3 version on the stable channel.  I'm only able to upgrade from 4.2 to 4.3 on the fast channel.  See attached screenshots.


Version-Release number of selected component (if applicable):

4.2 -> 4.3

How reproducible:

Always.

Steps to Reproduce:
1. Have 4.2.20 cluster
2. Attempt to upgrade to stable-4.3.z version
3.

Actual results:

Error!

Expected results:

Upgrade now!

Additional info:

Comment 1 Dan Yocum 2020-03-11 17:46:30 UTC
Created attachment 1669408 [details]
fast channel upgrade screenshot

Comment 2 Dan Yocum 2020-03-11 17:47:31 UTC
Additionally, we see this:

curl -sH 'Accept:application/json' 'https://api.openshift.com/api/upgrades_info/v1/graph?channel=stable-4.3' | jq '.nodes[].version'                                            
"4.3.2"
"4.3.1"
"4.3.3"
"4.3.0"


vs e.g. fast-4.3

curl -sH 'Accept:application/json' 'https://api.openshift.com/api/upgrades_info/v1/graph?channel=fast-4.3' | jq '.nodes[].version'                                                  
"4.2.18"
"4.2.19"
"4.2.16"
"4.3.3"
"4.3.1"
"4.3.2"
"4.2.21"
"4.3.5"
"4.3.0"
"4.2.20"

Comment 4 Stephen Cuppett 2020-03-13 14:12:13 UTC
The availability of code in the stable channel is published by the OTA process and made available by telemetry and follows a prescribed delay. It is there now.

Comment 5 yaoli 2020-04-26 01:38:51 UTC
Hello Team

Our customer want to upgrade from OCP 4.2.25 to OCP 4.3.

If the OCP 4.2.25 can not see stable-4.3

[root@prepare ~]# export CURRENT_VERSION=4.2.25
[root@prepare ~]# export CHANNEL_NAME=stable-4.3
[root@prepare ~]# curl -sH 'Accept:application/json' "https://api.openshift.com/api/upgrades_info/v1/graph?channel=${CHANNEL_NAME}" | jq -r --arg CURRENT_VERSION "${CURRENT_VERSION}" '. as $graph | $graph.nodes | map(.version=='\"$CURRENT_VERSION\"') | index(true) as $orig | $graph.edges | map(select(.[0] == $orig)[1]) | map($graph.nodes[.].version) | sort_by(.)'
[
  "4.2.26",
  "4.2.27",
  "4.2.28",
  "4.2.29"
]

But if the 4.2.29 can see stable-4.3

[root@prepare ~]# oc version
Client Version: openshift-clients-4.2.29-202004110432
Server Version: 4.2.29
Kubernetes Version: v1.14.6-152-g117ba1f
[root@prepare ~]# export CURRENT_VERSION=4.2.29
[root@prepare ~]# curl -sH 'Accept:application/json' "https://api.openshift.com/api/upgrades_info/v1/graph?channel=${CHANNEL_NAME}" | jq -r --arg CURRENT_VERSION "${CURRENT_VERSION}" '. as $graph | $graph.nodes | map(.version=='\"$CURRENT_VERSION\"') | index(true) as $orig | $graph.edges | map(select(.[0] == $orig)[1]) | map($graph.nodes[.].version) | sort_by(.)'
[
  "4.3.13"
]

customer said to me that 2 weeks ago, the stable-4.2 can upgrade to stable-4.3, but now can not upgrade direct?

So need update to 4.2.29 first, right? why can not upgrade direct?

Comment 6 yaoli 2020-04-26 03:28:53 UTC
Hello

from customer feedback they want to upgrade the ocp 4.2 to ocp 4.3 on May 1 - May 6, could you can help me confirm on 1th - 6th May can upgrade it?

Thanks

Comment 7 Stephen Cuppett 2020-04-26 10:58:34 UTC
For a stable upgrade, please follow the version graph. If currently it recommends 4.2.29, then you will need to upgrade to this version.


Note You need to log in before you can comment on or make changes to this bug.